Jump to content
browneye253

Programming Open / Close for ZWave Security Sensor

Recommended Posts

I added a Zwave security sensor that was setup in Vera to my project.  I then added a Door Contact Sensor to the project and connected the zwave contact sensor to the door contact sensor.  When I attempt to program against the open or close state's nothing happens.  If I program against the ContactState and check for true and false that is working.  Am I doing something wrong or is it maybe this particular zwave sensor passing the open / close in a way that's not expected?

I was able to setup a door relay and connect that to the arming relay of the sensor and the open / close programming works perfect for that.

Share this post


Link to post
Share on other sites

I have similar issue, spoke to C4, they couldn't figure out.

Any one can help, z-wave motions are less than half the price than C4

Share this post


Link to post
Share on other sites
On 11/7/2016 at 6:44 PM, browneye253 said:

I've been working around it by programming against the state.  More tedious but seems to be working.  Would be happy to find a fix though.

What do you mean when you say programming against state?

Share this post


Link to post
Share on other sites

Here's a screenshot of what I'm referring to.  I have a Zwave sensor that is paired with a generic C4 Sensor.  Then I program against the contact state of the C4 Sensor.

zwave_programming.JPG

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×