Baubas Cat

Announcement Audio Spike

8 posts in this topic

Does anyone have a workaround for the Announcement audio spikes? I don't want to adjust the level of my announcements. All my announcements are set to volume 40 so I am sure to hear them no matter what I'm doing. Is there something I can do to stop the current room from playing at volume 40 before the announcement plays? I am currently using pause/play and it stops the spike but because I listen to digital audio (Pandora, Napster) I get a long delay before the audio starts playing again after the announcement. Is there a better solution?

Share this post


Link to post
Share on other sites

Baubas Cat, I have not forgotten your request.

Here is a breakdown of previously described way to help resolve this issue.

This will cause the two rooms that may be playing music at a lower volume to "mute the sound before the announcement plays and just as the announcement plays, sets the volume to your desired announcement volume. After announcement duration wait 2 more seconds and then resume previously set volume for music.

To start, let's assume you have two rooms that you play your announcement in. Kitchen and bedroom. And that your trigger for the announcement is a doorbell driver. Called "Doorbell". Also, your announcement is 7 seconds long. And that you like to hear your announcement at 75% volume in both rooms.

Begin by going to the agents tab and editing your announcement to not set volume.

789dd39da9a1afdb768461a9cc9a80b0.png.

Under agents, Create two number variables named "kitchen Volume" and "bedroom Volume".

Under agents, create a macro called "announcement Volume".

In programming, on the left side, select the doorbell.

On the right side, select macro "announcement macro" and drag the green arrow into center.

Now on the left side, select "announcement macro" under "macros"

On the right side, select variables, then the right arrow on keyboard once to expose the variables. Select "Kitchen Volume" and then below, use the dropdown menu called "set to value of" and select Kitchen->Current_Volume. Drag the green arrow into the center area.

e89662918c7f3021c838c80a93addddb.png

On the right side, select variables, then the right arrow on keyboard once to expose the variables. Select "Bedroom Volume" and then below, use the dropdown menu called "set to value of" and select Bedroom->Current_Volume. Drag the green arrow into the center area.

On the right side select room "Kitchen" then press the right arrow on your keyboard three times to expose the room variables. Select "current_volume" and set current value =0. Drag green arrow into center of the screen.

987227554511f9faa0e2bd8310f9c754.png

On the right side select room "Bedroom" then press the right arrow on your keyboard three times to expose the room variables. Select "current_volume" and set current value =0. Drag green arrow into center of the screen.

On the right side, select announcements and select your announcement. Drag the green arrow into the center of the screen.

On the right side select room "Kitchen" then press the right arrow on your keyboard three times to expose the room variables. Select "current_volume" and set current value =75. Drag green arrow into center of the screen.

On the right side select room "Bedroom" then press the right arrow on your keyboard three times to expose the room variables. Select "current_volume" and set current value =75. Drag green arrow into center of the screen.

On the right side, select programming control, select delay, and set it to the length of your announcement plus 2 seconds. So 9 seconds. Drag the green arrow into the center.

On the right side select room "Kitchen" then press the right arrow on your keyboard three times to expose the room variables. Select "current_volume" and using drop down menu, set to value of ="variables->Kitchen Volume". Drag green arrow into center of the screen.

108194fe5d42df477f13dbcdf455fcdf.png

On the right side select room "Bedroom" then press the right arrow on your keyboard three times to expose the room variables. Select "current_volume" and using drop down menu, set to value of ="variables->Bedroom Volume". Drag green arrow into center of the screen.

This guide is my personal way of overcoming the issue of music spiking in volume for a second or so just as an announcement is triggered.

If the issue you are having is about the volume also spiking in rooms that are not on the announcement. Please refer to what funnyfarm Jas mentioned on previous post on the knowledge base. .

Happy Automating!

Share this post


Link to post
Share on other sites

Thanks, I feel I'm on the right track but here's my new issue. My announcements are tied to motion detectors around my property. When one of the detectors is triggered the announcement is played in three to six rooms depending on what the motion trigger is set to. With your workaround if I'm playing a source in those rooms the announcement plays without a spike and returns to the previous volume (Great) but if there is no source on in one of those rooms, when the room is turned on for the announcement, it plays the source from one of the other rooms. So if Pandora is playing in the Kitchen and Bathroom and the announcement triggers. The Kitchen and Bathroom will be set to vol.0 before the announcement executes but the Foyer (these are the three rooms grouped together) will turn on and play Pandora for a few seconds before the announcement executes. Is there a way to keep the rooms that aren't on before the announcement executes from playing the current source? Like I said, if all three rooms are on before the announcement your workaround is great but the rooms that are turning on for the announcement are not being set to vol.0. I'm hoping you have a fix that doesn't require setting the room default volume to 0. That might be a bigger inconvenience than the volume spike.

Share this post


Link to post
Share on other sites

23c1b61841216dad38a6153f97a67632.png

Use this in each room you want to stay quiet. Add it to the beginning of the macro. Before you execute the announcement. Remember that if that room has a default volume, it will return to that when you play a source. However, if that room does not have a default volume, it will be at zero volume when you play something again. You will have to manually increase volume from zero.

I recommend setting a default volume for each room that will be affected.

Happy Automating!

Share this post


Link to post
Share on other sites
23c1b61841216dad38a6153f97a67632.png

Use this in each room you want to stay quiet. Add it to the beginning of the macro. Before you execute the announcement. Remember that if that room has a default volume, it will return to that when you play a source. However, if that room does not have a default volume, it will be at zero volume when you play something again. You will have to manually increase volume from zero.

I recommend setting a default volume for each room that will be affected.

Happy Automating!

Just wanted to follow up, did this work out for you?

Happy Automating!

Share this post


Link to post
Share on other sites

Your programming worked except for whatever room wasn't on before the announcement would always turn on to the rooms default volume and not set it self to 0. The program scrip was correct so I'm not sure what the issue was. I changed all the rooms default volumes to 0 and the program works fine. I no longer get audio spikes. I just had to do some extra programming for the room volumes to set them self's to my desired volume when a source is selected. Thanks for your help.

Share this post


Link to post
Share on other sites

the latest snapshot driver handles all of these volume issues.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
    • 3 Posts
    • 176 Views
    • 7 Posts
    • 112 Views
    • 6 Posts
    • 116 Views
    • 2 Posts
    • 95 Views
    • 7 Posts
    • 107 Views
    • 4 Posts
    • 133 Views
    • 2 Posts
    • 150 Views