Jump to content
zaphod

Control4 and MQTT?

Recommended Posts


On 9/13/2017 at 1:45 PM, zaphod said:

Has anyone done  any work in integrating C4 and MQTT?  Such as writing an MQTT driver for C4?  This could be an interesting way to communicate to third party hardware.

 

https://github.com/mqtt/mqtt.github.io

i´m Looking for the same, because of the age of this post i think no one have a way to do it  =( 

how about use the homebridge on a rasberrypi with the driver on C4, and sonoff interface connected to it, does anyone make this work together?

Share this post


Link to post
Share on other sites

I have a full MQTT driver that supports SSL. I use the driver to control Sonoff kit but also it can send and receive any MQTT messages which can be used for programming. 

If you would like to help me beta test then give me your email address and I will send you the drivers.

Thank you

David

Share this post


Link to post
Share on other sites

Hi David,

that’s neat. I will give it a try. I have flashed a Neo Coolcam Wi-Fi wall plug (currently controlling it simply via HTTP) and I’m planning to flash my Mi LED Desk Lamp, both with Espurna.

Would be nice to have lightV2 dimmer sliders for the LED lamp (one for brightness, one for color temperature).

By the way, I think that the c4z files could be considered ‘releases’ (GitHub has a feature for that), they probably don’t belong to the git repo itself.

EDIT: Nevermind, I’ve just noticed you publish only the encrypted Lua portion of the drivers anyway, not the actual source code (not sure if that’s what’s GitHub intended for).

Share this post


Link to post
Share on other sites

Lukas, 

I'm just using GitHub purely to allow downloading and updating/installing the drivers rather than my own private web server.

Will have a look Mi Lamp and see how easy the dimming would be to do for a new driver.

Thanks

David

Share this post


Link to post
Share on other sites

Hi all!!

I discovered the Berto driver, and tested it with my Mqtt broker. It has the IP 192.168.1.100 and my sonoff tasmota the IP 192.168.1.120. But I can't make it work, there's no way.

I use the configuration like shown in the images David attached:

Server: mqtts://192.168.1.100 
Username: DVES_USER
Password: DVES_PASS
Topic:
...
...

Everything else like default.

I have no specific user or login into my broker, I actually can send messages with MQTTool app to the topic "cmnd/sonoff/power" and it works fine without any authentication, but I can't do the driver work. I've changed the server (with or without mqtts....) and writting the topic, but it doesn't seem to work ever.

What am I doing wrong?
Thank you very much!!!!
Best regards

Share this post


Link to post
Share on other sites
1 hour ago, muchachico said:

 

What is the model of the Sonoff Relay? There was an issue with the single channel relays which is now fixed.

If you have no authentication on your broker then make sure the username and password are blank.

Thanks

David

Share this post


Link to post
Share on other sites

HI David,

I started to test your great drivers...

Already done some great things with the MQTT Bridge!

Switching lights ON/OFF from or to C4 is ok, but dimming C4 lights seems to be impossible. I can't set my C4 dimmer LIGHT_LEVEL to the MQTT MESSAGE value (not listed)

Am I missing something?

Thanks

 

Share this post


Link to post
Share on other sites

Hi David,

Not sure if something has changed with the driver or it's me, but I'm not seeing messages from topics on the MQTT Driver properties page. The Sonoff relay driver is showing connected to broker and control works.

I'm using a Pi as a MQTT broker running Mosquitto (no username or password) and Node-RED for testing. Node-RED shows the messages from Control4 in debug but sending messages from Node-RED shows nothing in the driver. Topic subscribed is cmnd/#  (Sonoff with Tasmoto firmware)

Only started messing about with it on Thursday and same settings were working then ... 

Great driver!

Share this post


Link to post
Share on other sites

David,

I'm using it to control C4 dimmers and Hue lights (and some Ikea) via a Node Red Dashboard and some homemade ESP8266 MQTT buttons.

I sometimes have the same problem that NextGenAV exposed... and also MQTT IN programmation disappearing under "When A General Message is Received"... MQTT out programmation stays ok.

Capture d’écran 2019-02-10 à 19.05.51.png

Share this post


Link to post
Share on other sites

Thanks Christophe/NextGenAV.

Sometimes I've noticed that the MQTT bridge can lose subscriptions when drivers are added/updated. I'll look into this but in the mean time will add an Action option to refresh subscriptions to see if this sorts the issue next time you have the problem.

Share this post


Link to post
Share on other sites
17 hours ago, NextGenAV said:

Hi David,

Not sure if something has changed with the driver or it's me, but I'm not seeing messages from topics on the MQTT Driver properties page. The Sonoff relay driver is showing connected to broker and control works.

I'm using a Pi as a MQTT broker running Mosquitto (no username or password) and Node-RED for testing. Node-RED shows the messages from Control4 in debug but sending messages from Node-RED shows nothing in the driver. Topic subscribed is cmnd/#  (Sonoff with Tasmoto firmware)

Only started messing about with it on Thursday and same settings were working then ... 

Great driver!

Please update to V2, see https://github.com/davidmassot/Berto/blob/master/src/Berto_MQTTBridge/README.md.

Thanks

Share this post


Link to post
Share on other sites
19 hours ago, david@berto.co.uk said:

Thanks Christophe/NextGenAV.

Sometimes I've noticed that the MQTT bridge can lose subscriptions when drivers are added/updated. I'll look into this but in the mean time will add an Action option to refresh subscriptions to see if this sorts the issue next time you have the problem.

Thanks David,

Reprogrammed my TestRoom (Bureau) I let you know.

Many Thanks for your work!

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×