Jump to content
C4 Forums | Control4

Unable to successfully load a modified driver (.c4i file)


c4007

Recommended Posts

Hello,

I am trying to make very minor modifications to an existing driver I have (.c4i file), and for some odd reason it is not working.

Basically, I am doing the following:

1) Make a copy of the existing .c4i file

2) Edit the .c4i file and make a minor change (for example, just add one word into the “Documentations” section)

3) Copy the new modified .c4i file into Drivers directory (“C:\Users\MyUserName\Documents\Control4\Drivers”)

4) Start ComposerPro

5) Go to “Manage Drivers”… to see if the Driver Loaded properly

For some reason, the original file loads correctly – and shows up with the correct Device Type. However, my modified driver shows up as “Unknown”.

I have tried:

1) Making sure I only make a very minor change (just to test if I can get my own driver to load correctly), e.g., just change one word in Docs

2) I tried using various different text editors (Notepad, Visual Studio, Notepad++) and file encodings (ASCII, UTF-8, etc.)

3) Checking the Composer log file for any errors (none)

4) Even through the driver shows up as “Unknown” trying to use it anyway (it doesn’t work)

5) Searching through all the Forums… it seems a couple of other folks have encountered similar issues (but I did not see a resolution)

And I simply cannot figure out why I am unable to load my own driver successfully.

Any ideas/help would be greatly appreciated.

Thank you.

Link to comment
Share on other sites


Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...