Jump to content
C4 Forums | Control4

Kwikset Lock not showing in Composer


alexpopoff
 Share

Recommended Posts


Whatever dealer sold it to you would have to identify it in....EXACTLY according to the instructions that it comes with and/or using the info attached to the driver in composer.

If you got the lock from a retailer, you most likely don't have the proper kwikset lock to work in a C4 system.

Link to comment
Share on other sites

This took me a while to figure out, but originally I had my General Contractor purchase and install the Baldwin lock. We couldn't get it to work either. After a couple of days, we realized that there was no ZigBee card in the lock! Rookie mistake, sure, but that could explain your problem. We have a Baldwin which I believe is identical to the Kwikset except for appearance. My dealer then purchased the lock with the card in it as only authorized C4 dealers can by the lock w/ the ZigBee card. My lock also worked fine, but only locally. Once we added the ZigBee card to the lock, all worked fine w/ C4.

Link to comment
Share on other sites

  • 2 weeks later...

Thanks for the replies, sorry for the delay in my response,

I did get the Kwikset lock from my c4 dealer. The manual installation and code entry went ok. Then using Composer, the dealer did add the generic lock driver to the home and room, but when we go to Composer "Connections" tab to start the Identification process, the lock does not appear on the list, Shouod i be tryint ot find and use a driver specific for the the Kwikset lock?

Alex

Link to comment
Share on other sites

Thanks for the replies, sorry for the delay in my response,

I did get the Kwikset lock from my c4 dealer. The manual installation and code entry went ok. Then using Composer, the dealer did add the generic lock driver to the home and room, but when we go to Composer "Connections" tab to start the Identification process, the lock does not appear on the list, Shouod i be tryint ot find and use a driver specific for the the Kwikset lock?

Alex

Yes, you should use the specific Kwikset lock driver in addition to the generic lock driver. The Kwikset driver is how the lock is added to the Control4 system.

Link to comment
Share on other sites

I got this working, Both drivers are needed, the generic lock driver and the Zigbee lock driver, and the drivers need to be connected fo the control path to work. Once I added the Zigbee lock driver to the system deisgn, it showed up in the netowrk device Idenitifcation list and can be easily identified with the usuall 4 pushes of the lock ID button. All those steps require Composer pro. The Zigbee lock driver that is needed is named Black and Decker Zigbee lock driver, It works for the Kwikset locks, with the c4 Zigbee module.

thanks,

Link to comment
Share on other sites

  • 4 years later...
  • 1 month later...

Problems with ID for the Kwikset lock http://www.ebay.com/itm/Lock-Module-Control-4-Zigbee-Module-RF-Chip-for-Kwikset-5024093-/251285889873 See is apparently the one I have but I cannot get this to ID in composer regardless of what I do. Which driver would it be the kwikset or the Black and Decker? I have everything hooked up fine but it will not ID... Unless I am not pressing the correct button 4 times to ID? Pro says the left button 4 times but thats not clear at all? the #12 button? The Lock botton (not left button I know) or the "smart code" left button? Thanks guys

Link to comment
Share on other sites

  • 1 year later...

How to factory reset a Kwikset Zigbee Lock:

  1. press the right button 9 times to disband the lock
  2. pull the battery out
  3. press the program buttons a few times, the lock may squeal
  4. press and hold the program button as you drop the battery back in. Hold it for 5 seconds

 

keep in mind it will need to be reporgrammed

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...