Jump to content
C4 Forums | Control4

Seeing MP3 music on networked computer.

All Wired Up!

Recommended Posts

OK... I want to stream music from a computer through a router ---> HTC ---> C4 Amp --> 8 zones. The question is how do I "see" that music? I know it needs to be a shared file but what do I do in composer or do I use Media Edition or???

Also, since the Amp is on the network do I need stereo cables between the HTC and amp or does it stream digital from HTC?


Link to comment
Share on other sites

Hehe, I got this working at my own house and it is AWESOME. Unfortunately all my files are WMV :( First, go to System Design (in Composer full version) Select My Drivers. Down at the VERY bottom of the list select Network Storage Device. Add that to your system. Still under System Design, select Network Storage Device. Browse to the location of your music files (make sure the destination folder is shared) and press connect. If it connects, you're in business! Select Digital Audio under the Media tab and scan your system.

Post back if you have any problems.

Link to comment
Share on other sites

Getting an error messege when trying to connect. I've disabled Norton and XP Firewall on customer computer, went from my wireless connection to wired, moved shared file to C drive, still same error.

Do I need the login and pass for a user? Any ideas?

I have an image but in the general forum it said just click add image. I did and all I get is the IMG open closed thingy. How do I actually post an image?


Link to comment
Share on other sites

you should never share your root directory. very bad practice.

but there is no reason why you can't just share the folder that is needed that i can think of.

i create a folder in the root called "music". i put all my music in there in this format:














the album folders contain all the actual mp3's for that album.

then i share the music folder

i then go to any machine that may need access seperately and create a mapped drive to that folder labeled "m:" (for obvious reasons)

if you're using a network storage drive, map a drive letter to the music folder on it.

Link to comment
Share on other sites

I am having a similar issue with my laptop and sharing the associated folder. I have my laptop that I am using with the Composer software on it, hard-wired to the switch. I have shared the folder, and can view the folder if I click Start-Run- and enter the computer name, but when I try to browse to the folder in composer, it will not let me get past the workgroup name (Entire Network - Microsoft Windows Network - Mshome(workgroup name)), and then I can't click ok to complete. I am pretty sure it has to do with my network settings, but I have re-run the network wizard to no avail. Help!

Link to comment
Share on other sites

Exactly. I put a folder directly on the root drive of the customers PC and enabled sharing. I put the music in there. I then added a network device in composer and attempted to browse to the folder following the same path as the above post. I see it fine but when I choose it and click connect the progress bar goes about 20% of the way then it gives me an error. The only way I could get it to connect was to share drive C. Hmmmmm.

Link to comment
Share on other sites

try renaming the share to "music" instead of "PC Music". If you have proper access to that share, that should fix your problem. The space between PC and music isn't properly interpreted, and throwing off the mount. Linux doesn't like spaces that aren't properly syntaxed.

Link to comment
Share on other sites

Yes, it was either the space or the 12 character limit that the older OS's don't like. Either way, it worked.

I can't imagine it would have been the 12 character limit only because that limitation hasn't existed since DOS/win3.x/win95. Linux/OSX/winxp all support long file names.

When in doubt, use underscores as opposed to spaces and mind your case-sensitivity (i.e. pc_music, instead of pc music, and/or PC_music is different from pc_music).

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...