Jump to content
C4 Forums | Control4

Honeywell Vista 4232cbm Programing help needed


Recommended Posts

Trying to intergate a vista 20p into control4. I've tried everything and I cannot get the 4232cbm programmed right.  The light is still flashing fast on the cbm board so I believe the issue is with the programming to the panel not my setup into control4.   I've followed all the directions both the ones here (*91, 8, 2, and *189, 1,5,1,1) posted by a user, the ones in the driver, and the official ones here https://library.ademconet.com/mywebtech/mwt/fs2/4232CBM/4232CBM-Installation-Instructions.PDF.

As background its a 20p, has two tuxedo touches set up, one touch is on ecp 6, the other is on ecp 1.  If anyone has any ideas can you please share what i might be doing wrong?  Also is there a way to reset all the panel information without reseting the zones?  If there is I'd be happy to try that..., Thanks in advance! 

Link to comment
Share on other sites

Ok this thing is driving me CRAZY! 

So I figured I had tried everything it must be the CBM module I have is bad.  Bought a new one.... No luck.   Contacted Honeywell support they couldn't help.  Only a fast LED flash on the one LED signalling the configuration isn't set up.   

So then I tried the commercial cbm driver, no luck, but after I read a user here posted that the commercial driver can mess up your vista settings.  So i figured screw it, did a *97 reset on the vista 20p and lost all my zones etc.  Figured maybe that would fix things, nope...

Then I figured maybe the cheap 3.5mm to serial and serial to Ethernet cable and converter I bought on amazon are bad, so I set them up to control my marantz amp just to test them out, amp works fine over serial with the exception that it won't send the turn the amp on but it was sending all the change inputs and volume commands just fine so I figure the adapters are fine?

At a complete loss as to what else it could be... Anyone have any ideas?

4232cbm driver (residential) debug say:
.   ACTION:  Establish4232Communication
GetPanelConfiguration already in progress! Exiting out of StartGetPanelConfiguration()
.   ACTION:  GetPanelConfiguration
GetPanelConfiguration already in progress! Exiting out of StartGetPanelConfiguration()
OnGetPanelConfigurationTimeoutTimerExpired: RequestNumberOfPartitions Failed, stating GetPanelConfiguration again!

Link to comment
Share on other sites

  • 2 months later...

I can relate to your frustration here.  I faced the same frustration on my Vista 20p and there are many things that can go wrong.  I spent days getting it working.

In my case the issue was with the CBM itself.  I found out that there are ADT versions of the CBM that won't work.  I ordered a new one on ebay and it fixed it for me. 

This is after I tried every single possible piece.  Here are some things you will want to check.  It also won't work if you have TotalConnect 2.0 setup.

What is your Firmware version on your chip inside your panel?  This only support on firmware above 9.12.

1.) The keypad address is key.  It sounds like you already have two other AUI keypads. The vista 20p only supports four so the CBM will take up one of these addresses.  Here are the only spots you can have. 1, 2, 5 and 6.  You'll want to make sure that all addresses 1,2,5 & 6 are enabled.  Read the Honeywell documentation.  The documentation in the driver talks about enabling a keypad in the 17 range. This is not correct and is not needed. I would set your keypad address to 2 as that seems like an open spot for you.  You set this in the driver. 

2.) Make sure the RX and TX are correct.  I banged my head against the wall on this one. I actually did a pin out with my meter to double check everything.  Here is the image I referenced. 


Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...