Jump to content
C4 Forums | Control4

Unable to download C4 OS3 app on iPad Mini 2 running 12.5.4


Recommended Posts

About 2 weeks ago I got a notice on my iPad that there's a new version of Control4, I went ahead and tried to download it.  However, the app would spin and after a few mins, it either tells me unable to download the app, or it just gives a dark icon on the screen and I can't use the C4 app!

I went ahead and factory reset my iPad, still the same problem.  I have no problem installing other apps, just the C4 app!  I wonder if it has to do with an older iOS OS of 12.5.4 running on the iPad Mini 2!  I don't want to upgrade the iPad as it has a LaunchPort dock!

Any help would be greatly appreciated.

Link to comment
Share on other sites

Hi @htjunkie,
The reason the app won't download/function is that the minimum iOS version compatible with the Control4 OS 3 app is iOS 13.  The iOS team has a ticket open with Apple to figure out why the iOS App Store lists it as compatible with iOS 11 since this is incorrect and they can't find anything in code that would possibly be causing this to show wrong on the app store. The Control4 OS 3 app was originally released with support for iOS 12 back in May 2019, but has since been forced up to iOS 13 due to some API requirements.

Link to comment
Share on other sites

  • 3 months later...

A while back I could do it as long as I have the older version of the app downloaded to my computer with iTunes.  I haven't done it in a while since all the updates and sync are cloud based, don't need to plug iPad to computer for anything.

I also remember in the past, App Store would offer the latest one would not work and offered to download the older version, didn't see that either!

Link to comment
Share on other sites

  • 3 weeks later...

I believe the only way you can get an older version is if you had it installed previously then the app store is supposed to let you download the newest version that is compatible, but that is all handled by the OS & Apple's app store so I don't know the steps to make this happen.  It sounds like htjunkie was able to get this to work at some point in the past.

Link to comment
Share on other sites

  • 2 years later...
On 9/9/2021 at 5:23 PM, htjunkie said:

Thanks for the update, I'm using an iPort wall dock for this iPad Mini, hoping to make it last as long as I can.  I have since replaced it with a Mini 5 and all is well.



Quick question... Just bumped on the same issue. Upgraded my system and now i cannot use my iPad minis that are on the wall using iPort mounts..


Did u managed to use iPad mini 5 on the same mount as iPad mini 2? Their dimensions differ by 3 millimeters, and i', afraid it wont feet. So if it is working for you that is great news for me. Pleas let me know.




Link to comment
Share on other sites

For my iPort, it came with both iPad Mini 2 and Mini 4 sleeves.  It's more an extra adapter for Mini 4 as it's slightly longer.

Since the Mini 4 and Mini 5 are the same physically so I was able to use the same sleeve for my iPad Mini 5.  I guess the question is if you had the iPad Mini 4 partial sleeve.

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.