Jump to content
C4 Forums | Control4

Network Connectivity Issues with NEEO Remtoe


Recommended Posts

I have had a NEEO remote for approximately a year, when it was supplied with a new EA3 processor and system installation. Since new, we have continuously experienced network connectivity issues between the NEEO and the Control4 EA3 processor. The connectivity issues present as lag (e.g. 2 second), spinning wheel, and a couple of errors including the one shown in the attached screen shot.

Our NEEO remote is used in very close proximity to a high quality, business class WiFi access point (Netgear Prosafe WAC720). Signal strength is stellar (RSSI reported by the NEEO is -47) and I don't experience connectivity or throughput issues with any other devices connected through the access point; in fact, I have stellar network performance with other devices. The network is configured with Cat6 wiring and a gig switch (Netgear 28PT GE POE Smart Switch). The EA3 is connected by ethernet to Netgear Prosafe switch.

When the NEEO remote acts up, I have tried various things to get it temporarily working again, including rebooting the NEEO, the WiFi access point, and the EA3 processor. At times, each of those have seemed to work temporarily, but that might be just coincidence because sometimes waiting a brief period of time caused the problem to temporarily resolve itself.

We get all sorts of weird behaviour on the NEEO. For example, right now I'm trying to enter the "Settings" screen. when I click Settings, I get the spinning wheel for 30 seconds and then it goes back to same menu I started with. Click settings again, spinning wheel for 30 second and back to the same menu I started with. But, do this four times and on the fourth attempt it actually goes into settings.

I would appreciate any insight or suggestions as to how to get the NEEO working such that it provides a decent user experience. As presently working, it is a terrible user experience.

NEEO Network Error - screen shot.jpeg

Link to comment
Share on other sites


14 minutes ago, lippavisual said:

Create a separate Wifi SSID just for the NEEO.  That should help connectivity issues.  What version is the remote running?  Wondering if it is not receiving updates because of your connectivity problems.

The NEEO firmware version is 1.71.3-30626811. Is that the current version?

The Netgear WAC720 access point supports one SSID for 2.4 GHz and one SSID for 5.2 GHz (there are unique SSIDs for each band and it is the only operating access point in the home right now). I would need to install another access point immediately adjacent to the existing one to add an SSID. That is not an ideal scenario from a bandwidth conflict management perspective. Why would I need a dedicated SSID for the NEEO; the access point is currently serving a dozen or so devices between the two frequencies... it should be able to handle a much greater number.

Link to comment
Share on other sites

I have the same problem with my NEEO. My Access Point is in the same room, maybe 12 feet away, and I still get dropouts. Oddly, it seems to happen in spurts. It will be fine for weeks or months at a time, and then I get constant dropouts for a few days. In anticipating of the new remotes coming out, I have not gotten too frustrated with the NEEO, as I hear this is a very common problem. 

Link to comment
Share on other sites

21 minutes ago, BY96 said:

I have the same problem with my NEEO. My Access Point is in the same room, maybe 12 feet away, and I still get dropouts. Oddly, it seems to happen in spurts. It will be fine for weeks or months at a time, and then I get constant dropouts for a few days. In anticipating of the new remotes coming out, I have not gotten too frustrated with the NEEO, as I hear this is a very common problem. 

That does sound like a very similar if not identical scenario. I have very similar proximity to my WiFi access point (with -41 RSSI, which is stellar) and if I speed test my WiFi when the NEEO is acting up, I get ~300Mbps on an iphone standing further away. I also experience the spurts/periodic issues. It can work OK for a period of time and then it works badly for a period of time and then get to the point where it barely works or doesn't work at all.

Have you tried seeking a resolution through the Control4 Customer Advocacy service?

Link to comment
Share on other sites

4 minutes ago, PumpUpVolume said:

That does sound like a very similar if not identical scenario. I have very similar proximity to my WiFi access point (with -41 RSSI, which is stellar) and if I speed test my WiFi when the NEEO is acting up, I get ~300Mbps on an iphone standing further away. I also experience the spurts/periodic issues. It can work OK for a period of time and then it works badly for a period of time and then get to the point where it barely works or doesn't work at all.

Have you tried seeking a resolution through the Control4 Customer Advocacy service?

I asked my dealer about it awhile back. He said it was a very common issue and to make sure the NEEO is on 2.4Ghz, which it is in my case. Honestly, knowing I have a new remote coming in a few months has left me without the drive to tackle the issue. However, I will be moving the NEEO to the master bedroom, which is further from the AP, so I may be dealing with it in the future. 

Also, any time I seem to get frustrated, it starts working again without any dropouts (as it has been for several weeks now). My up-time is much more than my down-time. 

Link to comment
Share on other sites

2 minutes ago, BY96 said:

I asked my dealer about it awhile back. He said it was a very common issue and to make sure the NEEO is on 2.4Ghz, which it is in my case. Honestly, knowing I have a new remote coming in a few months has left me without the drive to tackle the issue. However, I will be moving the NEEO to the master bedroom, which is further from the AP, so I may be dealing with it in the future. 

Ours’ drop out periodically (ruckus aps) and we couldn’t get them to work at all with ubiquiti. I’m asking our dealer now if c4 will replace them with halo touches. Don’t think C4 is incentivized to support neeo in long run and this was a pivot (away from neeo — ostensibly their future architecture). They should do right by customers and provide free switch to Halos. 

Link to comment
Share on other sites

32 minutes ago, BY96 said:

I asked my dealer about it awhile back. He said it was a very common issue and to make sure the NEEO is on 2.4Ghz, which it is in my case. Honestly, knowing I have a new remote coming in a few months has left me without the drive to tackle the issue. However, I will be moving the NEEO to the master bedroom, which is further from the AP, so I may be dealing with it in the future. 

Also, any time I seem to get frustrated, it starts working again without any dropouts (as it has been for several weeks now). My up-time is much more than my down-time. 

I got the same advice - to make sure it is in 2.4 GHz. The NEEO doesn't have a 5.2 GHz radio, so what else would it be on? Seriously. I have a RSSI of -41 db (as reported by NEEO in the Settings section), which is laboratory perfect conditions for a WiFi connection. It is not a weak connection issue; something else is going on.

Link to comment
Share on other sites

59 minutes ago, PumpUpVolume said:

I got the same advice - to make sure it is in 2.4 GHz. The NEEO doesn't have a 5.2 GHz radio, so what else would it be on? Seriously. I have a RSSI of -41 db (as reported by NEEO in the Settings section), which is laboratory perfect conditions for a WiFi connection. It is not a weak connection issue; something else is going on.

Note that the recommendation would be to make sure the SSID the Neeo is on is a 2.4Ghz ONLY channel - as in not use a mixed channel SSID for them

Link to comment
Share on other sites

4 minutes ago, Cyknight said:

Note that the recommendation would be to make sure the SSID the Neeo is on is a 2.4Ghz ONLY channel - as in not use a mixed channel SSID for them

I have unique SSIDs for each of my channels. I do not have a common SSID for the two bands. There is only one 2.4GHz access point and one 2.4 GHz SSID in my house and that is what the NEEO uses. I do have a 5.2 GHz access point, but it has a different/unique SSID.

Link to comment
Share on other sites

1 hour ago, LollerAgent said:

Yeah - this is a fairly common issue, unfortunately. 

A dedicated 2.4Ghz SSID helps, but I still go through spurts where they just wig out and drop/reconnect to WIFI several times.  

Your description of what happens with a dedicated 2.4GHz SSID perfectly describes my current state. It doesn't sound a like a good investment to add a parallel network only to experience more of the same.

Link to comment
Share on other sites

6 minutes ago, lippavisual said:

Are you blocking anything on the Wi-Fi network?  Multicast filtering?

I have neeo’s on both Ruckus and UniFi and do not experience any problems with them.

I am not blocking anything on the WiFi network.

I am not using multicast filtering.

Router is supplied by ISP and is in minimal/default configuration with all radios turned OFF. The router is the very widely deployed Bell Home Hub 3000.

Netgear Prosafe 28PT GE POE SmartSwitch is pretty much out of the box configuration; nothing fancy going on here... it's pretty much running as an unmanaged switch.

Netgear Prosafe WAC720 access point is also minimal configuration with unique SSID for each 2.4 and 5.2 GHz bands. These are the only two access point radios active in the house. Nothing fancy going on here either.

If I run a speedtest to my ISP through all devices (access point, switch, and router) using OOKLA from an iPhone I get a consistent 250 - 300 MBPS from much further away than where the NEEO is used.

I have ~20 devices on the network, but most are connected by ethernet; there is only very light use of the WiFi netwok in the house as all high demand end points have ethernet connections.

The rest of the 20 devices perform flawlessly. The NEEO is a nightmare.

Thoughts and ideas are welcome and invited !

Link to comment
Share on other sites

18 minutes ago, lippavisual said:

Are you blocking anything on the Wi-Fi network?  Multicast filtering?

I have neeo’s on both Ruckus and UniFi and do not experience any problems with them.

Also note that another member said (above), "we couldn’t get them to work at all with ubiquiti"; you seem to have had a different experience with ubiquiti.

Link to comment
Share on other sites

Are you on 20mhz channel width for your 2.4 radio? Your AP defaults to 40 which buys you nothing but problems on 2.4.

Turn off auto channel selection if you haven't already done so.

Turn off any "block on excessive retransmits" etc. 

If you make those changes, bounce the 2.4 radio and bounce the neeo or force a reconnect.

Link to comment
Share on other sites

16 minutes ago, SpencerT said:

Are you on 20mhz channel width for your 2.4 radio? Your AP defaults to 40 which buys you nothing but problems on 2.4.

Turn off auto channel selection if you haven't already done so.

Turn off any "block on excessive retransmits" etc. 

If you make those changes, bounce the 2.4 radio and bounce the neeo or force a reconnect.

See the attached screenshot for current radio configuration settings. You can see that it is already set to a 20mHz bandwidth. Are there any other settings you recommend checking or changing? The screenshot shows the configuration that has been in place for months - with terrible performance from the NEEO.

Screenshot of WAC720 Radio Configuration.gif

Link to comment
Share on other sites

9 minutes ago, PumpUpVolume said:

See the attached screenshot for current radio configuration settings. You can see that it is already set to a 20mHz bandwidth. Are there any other settings you recommend checking or changing? The screenshot shows the configuration that has been in place for months - with terrible performance from the NEEO.

Screenshot of WAC720 Radio Configuration.gif

Get off channel 3. Pick 1, 6 or 11. You will want to perform a site survey to determine which one to use. 

If you have no b devices, select 11ng. 

I'd move guard interval to long 800. 

Pick a set power level. I know you're single AP, but Netgear will actually fluctuate transmit power depending on throughput (I believe you're 2x2 which won't take much to force a change). 

Link to comment
Share on other sites

Make sure wifi sleep is disabled in the remote.  Your battery will die a bit faster but it will never disconnect from the wifi and reconnect.  Another thing I'll mention is if you have multiple WAPs blacklist the Neeo from all of them except the one you want it to connect to.  I've seen those things jump on WAPs with much worse signal then the one right in the room.  Last thing I'll bring up is ISP routers suck for these systems, just in general.  I pretty much refuse to do a system without putting in a solid router.  That may not be the issue you're having here but just a general recommendation. 

Link to comment
Share on other sites

2 minutes ago, mstafford388 said:

Make sure wifi sleep is disabled in the remote.  Your battery will die a bit faster but it will never disconnect from the wifi and reconnect.  Another thing I'll mention is if you have multiple WAPs blacklist the Neeo from all of them except the one you want it to connect to.  I've seen those things jump on WAPs with much worse signal then the one right in the room.  Last thing I'll bring up is ISP routers suck for these systems, just in general.  I pretty much refuse to do a system without putting in a solid router.  That may not be the issue you're having here but just a general recommendation. 

I only have one (1) WAP at this time (plan to add one or two more in the future, but only need one now), so no option to block NEEO on other WAPs.

How do I disable "sleep mode"?

I haven't put a router behind the ISP router because it forces double NAT, which I'd prefer to avoid.

Link to comment
Share on other sites

9 minutes ago, SpencerT said:

Get off channel 3. Pick 1, 6 or 11. You will want to perform a site survey to determine which one to use. 

If you have no b devices, select 11ng. 

I'd move guard interval to long 800. 

Pick a set power level. I know you're single AP, but Netgear will actually fluctuate transmit power depending on throughput (I believe you're 2x2 which won't take much to force a change). 

I don't have a device handy that I can use for a site survey, so I'll try channel 11 for now and plan to do another site survey asap.

I don't believe I have any 11 b devices, so I'll try 11ng; I suppose if I have a b device, I'll discover that quickly enough as it will stop working with the new settings.

Power level is a set level. It is set to full. That is not a modulating level. The only other options are half, quarter, eighth, minimum.

I've attached a screenshot of the new settings.

Screenshot of WAC720 Radio Configuration - new settings.gif

Link to comment
Share on other sites

28 minutes ago, PumpUpVolume said:

I only have one (1) WAP at this time (plan to add one or two more in the future, but only need one now), so no option to block NEEO on other WAPs.

How do I disable "sleep mode"?

I haven't put a router behind the ISP router because it forces double NAT, which I'd prefer to avoid.

Wifi sleep mode is under NEEO settings in Composer HE.

You don't have to double NAT if you can put your isp router into "bridge" mode.

I would STRONGLY suggest that if you're going to build out a multi AP network, you ditch Netgear WAPs. 

Link to comment
Share on other sites

1 minute ago, SpencerT said:

Wifi sleep mode is under NEEO settings I'm HE.

You don't have to double NAT if you can put your isp router into "bridge" mode.

I would STRONGLY suggest that if you're going to build out a multi AP network, you ditch Netgear WAPs. 

I see only two settings that are changeable:

1) Beep when docked;

2) Adaptive Brightness.

There is no setting for WiFi sleep.

I'm not deploying a multi AP network for the foreseeable future. I'll deal with that issue when I get to it. My short term goal is to solve the NEEO issue.

Link to comment
Share on other sites

6 minutes ago, PumpUpVolume said:

I don't have a device handy that I can use for a site survey, so I'll try channel 11 for now and plan to do another site survey asap.

I don't believe I have any 11 b devices, so I'll try 11ng; I suppose if I have a b device, I'll discover that quickly enough as it will stop working with the new settings.

Power level is a set level. It is set to full. That is not a modulating level. The only other options are half, quarter, eighth, minimum.

I've attached a screenshot of the new settings.

Screenshot of WAC720 Radio Configuration - new settings.gif

Changing to these settings did not work. The NEEO is presenting huge lag with the new settings. Other devices still work fine. Can still stream video from my SkyBell and still get >250MBPS through the WAP to the ISP. All devices work great except the NEEO, which is terrible.

Link to comment
Share on other sites

2 minutes ago, PumpUpVolume said:

I see only two settings that are changeable:

1) Beep when docked;

2) Adaptive Brightness.

There is no setting for WiFi sleep.

I'm not deploying a multi AP network for the foreseeable future. I'll deal with that issue when I get to it. My short term goal is to solve the NEEO issue.

Oh, and putting my ISP router into bridge mode is complicated... and the moment I do, my ISP won't support me if anything goes wrong with my IP TV, which does happen occasionally. So, going to bridge mode on the ISP router is not a practical option as it just opens up a bigger can of pain. Also, note that I don't have the common Bell Home Hub 3000 which is deployed in Ontario. I have  Manitoba one which has different firmware and features. All the documentation posted online for jailbreaking the Home Hub 3000 applies to the Ontario one and not the MB one.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...