Jump to content
C4 Forums | Control4

2.0 and a new 7" tabletop touchscreen problem


Recommended Posts

litterally 6 hours today wasted trying to update a brand new 7" table top touchscreen to 2.0. It keeps error-ing out and will not update.

Current version is out of the box, trying to use update manager to go to

Screen changes to Downloading PreUpgrade Setup, stays that way for a long time then comes up with failed update.

Any help would be appreciated.

Link to comment
Share on other sites

yes, many times. also the HC500 just to try that. Took the cover off and tried to reset it, and use the restore USB stick and even tried the USB stick as an install stick. The unit didn't even acknowledge the usb at all and just booted up the same as it had been.

Before I tried to update the unit it powered up and had the old Control 4 log and layout and I could touch between screens SO I know it worked. The update process is what messed it up.

I tried the button 2 & 3 thing over a sozen times and at about 4 am decided to go to bed before I smashed the pile of ____.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.