Jump to content
c4forums | The Control4 Community

House alarm notification question


Brent87

Recommended Posts

I have our house alarm system connected to C4 and programmed it to send me push messages to my phone when it's activated, deactivated or if the alarm is tripped.

About a month ago our cleaning service tripped the alarm and the push message "alarm tripped" was sent every second until I shut down the alarm.   It was annoying since I couldn't deactivate the alarm from my phone due to all the incoming push notifications...my phone was going crazy.   After that episode, I put in a timer so that it would only give me the "alarm tripped" notice once per minute if the alarm tripped and thought that fixed it.

Well today the cleaners tripped the alarm again and I got the "alarm tripped" notice once every minute (like I programmed), but I also got the push notice for "alarm set to away mode" every second.  So I fixed one issued but created another somehow.   Not sure why that "alarm set to away" would keep being sent like that and not sure how to stop it.   I have that push notice set up to send only when we set the alarm to away mode (of course) so not sure why it would be continually re-sent when the alarm is tripped.   Has anyone seen this before?

Link to comment
Share on other sites


Can't say I've seen it - but in general it's strongly advisable to use a variable on ANY message (that you can reset using a schedule or timer in whatever timeframe you want).

 

It could simply be the cleaners pushing buttons of course, of perhaps the panel 'resends' the armed to away status upon alarm to indicate the state prior to alarm.

Link to comment
Share on other sites

Thanks Cyknight,

I don't think it was the cleaners pushing buttons since it was sent about 50 times (at least I hope they weren't that clueless).   I think the panel was resending the away status like you state.  I guess the easiest fix it to put in on a time too.   I'll do that tonight and then wait until the cleaners trip it again to see what happens.

I actually shouldn't blame the cleaners as the are entering a code in a C4 connected kwikset deadbolt lock to the garage.  That code is set to de-activate the alarm (only during times they should be there).   When the battery in the kwikset gets low, it apparently doesn't send a strong enough signal to the alarm so it doesn't get deactivated.  I have it set up to send me a notice when the battery is low, but didn't get it this time.  I'll have to check that as well. 

Link to comment
Share on other sites

19 hours ago, Brent87 said:

Thanks Cyknight,

I don't think it was the cleaners pushing buttons since it was sent about 50 times (at least I hope they weren't that clueless).   I think the panel was resending the away status like you state.  I guess the easiest fix it to put in on a time too.   I'll do that tonight and then wait until the cleaners trip it again to see what happens.

I actually shouldn't blame the cleaners as the are entering a code in a C4 connected kwikset deadbolt lock to the garage.  That code is set to de-activate the alarm (only during times they should be there).   When the battery in the kwikset gets low, it apparently doesn't send a strong enough signal to the alarm so it doesn't get deactivated.  I have it set up to send me a notice when the battery is low, but didn't get it this time.  I'll have to check that as well. 

this is interesting since i have a similar setup. i use the kwikset 916, and upon entering a valid code during preset times of the day, it sends my PIN to the alarm to deactivate it. i've tested it thoroughly and it works well, even if the alarm is tripped (but not alarming) before c4 finishing sending the code to the alarm panel. 

some questions for you though: i assume you have c4 doing the disarming of the alarm and it's simply an action in programming that you've configured? also, if the battery was low, were you being notified by the lock that the battery was low? or was it some arbitrary level above any warnings when the RF wasn't reaching back to the controller?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...