Jump to content
c4forums | The Control4 Community
  • 0

How to add a Time Warner Cable box driver


deeonline

Question

Hi,

I am trying to add a cable box to one of the rooms so I can control it with HC800 IR emitter. I select the room, double click "Cable" driver under "My Drivers -> Audio/Video" and select "Time Warner" form the manufactures list. But all it does is just adds "Time Warner Icon Pack" entry in the room and there is nothing for me to connect the controller's "IR OUT 1" output to (in other words "Connections -> Home Controller HC800 -> Control Outputs/IR OUT1" is blank). This seems to work with the "Satellite" driver. Am I missing something?

My controller and ComposerPro is 2.8.1

Thanks.

 

Link to comment
Share on other sites

18 answers to this question

Recommended Posts

And the final update. I've got it somewhat working for now. I've selected Motorola as the manufacturer since it looks like Arris and Motorola are related somehow and picked DCH3200[IR] (Icon Ready) as the box model, since this is the closest to DCX3200-M. So far, I am able to control the basic features (changing channels, bringing up guide, play, stop etc.). I am happy. :)

Link to comment
Share on other sites


Yes, I saw these in the Documentation tab for the "Time Warner Icon Pack". And I've already tried renaming the driver from `timer_warner_cable_icon_pack.c4z` to `my_cable_provider.c4z` as instructions state and re-adding it back to the project, but didn't notice anything different. I still see "Time Warner Icon Pack" as the only item being added to the project and there is still nothing I can connect the HC800  "IR OUT 1" control to. The list is blank. Searching the database for "cable" doesn't bring back anything that would have "Icon Ready" next to it as the instructions say. I have a feeling I am not seeing the cable driver in the search results for some reason.

Link to comment
Share on other sites

I think I see what I maybe doing wrong. When I double click "Cable" under "Audio/Video", I was selecting "Time Warner" as the manufacturer. But Time Warner is not the manufacturer of the set top box. "Arris" on the other hand is. So, when I select Arris as the manufacturer, I see only two options and my cable box is not listed there. I guess I am out of luck since there is no cable driver for Arris DCX3200-M yet (http://www.arris.com/products/dcx-3200m-p3-all-digital-set-top/).

I could probably get a different box from the Time Warner. If anyone can recommend one please feel free to chime in. Thank you @Cyknight and @msgreenf for really trying to help. You knowledge and expertise is very much appreciated.

Link to comment
Share on other sites

9 hours ago, deeonline said:

I think I see what I maybe doing wrong. When I double click "Cable" under "Audio/Video", I was selecting "Time Warner" as the manufacturer. But Time Warner is not the manufacturer of the set top box. "Arris" on the other hand is. So, when I select Arris as the manufacturer, I see only two options and my cable box is not listed there. I guess I am out of luck since there is no cable driver for Arris DCX3200-M yet (http://www.arris.com/products/dcx-3200m-p3-all-digital-set-top/).

I could probably get a different box from the Time Warner. If anyone can recommend one please feel free to chime in. Thank you @Cyknight and @msgreenf for really trying to help. You knowledge and expertise is very much appreciated.

Try using the Cable driver manufacturer Scientific Atlantia Explorer 8300HD. Should give you all the connections you need and match up with TWC's remotes.

 

Link to comment
Share on other sites

8 hours ago, deeonline said:

And the final update. I've got it somewhat working for now. I've selected Motorola as the manufacturer since it looks like Arris and Motorola are related somehow and picked DCH3200[IR] (Icon Ready) as the box model, since this is the closest to DCX3200-M. So far, I am able to control the basic features (changing channels, bringing up guide, play, stop etc.). I am happy. :)

Yes that would work too. Motorola's cable box division was purchased by Arris, so they are one and the same. :)

Link to comment
Share on other sites

Hi,

I am trying to add a cable box to one of the rooms so I can control it with HC800 IR emitter. I select the room, double click "Cable" driver under "My Drivers -> Audio/Video" and select "Time Warner" form the manufactures list. But all it does is just adds "Time Warner Icon Pack" entry in the room and there is nothing for me to connect the controller's "IR OUT 1" output to (in other words "Connections -> Home Controller HC800 -> Control Outputs/IR OUT1" is blank). This seems to work with the "Satellite" driver. Am I missing something?

My controller and ComposerPro is 2.8.1

Thanks.

 

Review the release notes. Icon drivers ≠ device drivers.

Sent from my Nexus 5X using Tapatalk

Link to comment
Share on other sites

7 hours ago, funnyfarm299 said:

Review the release notes. Icon drivers ≠ device drivers.

Thank you for your reply. I understand they are different. What I don't understand is why the icons are the only once that get added when I double click on the "Cable" icon in the "My Drivers -> Audio/Video" section? Should I choose some other driver instead of "Cable"? After all, this works properly when I double click on the "Satellite" driver, so I'd expect adding a cable box would be a similar experience too.

Please let me know if you need any additional info.

Link to comment
Share on other sites

Thanks. I've search for "Media Proxy" in the "Search" tab and these are the top matches found:

  1. Media Controller
  2. Digital Media
  3. Media Player[DriverWroks]
  4. Media Player V2[DriverWorks]

Should I use one of them to add the cable box to the system?

 

Link to comment
Share on other sites

31 minutes ago, Cyknight said:

?

Oh my.

Look I don't want to sound harsh but...are you sure you know what you're doing? Because it sounds like you're in over your head...

 

You'd search for the device, not the proxy.

Not sure anymore. :) I've added and connected a bunch of other devices and didn't have any issues. This is my first time trying to add a cable box. I am trying to follow the instructions. I believe I am searching through devices, because the dropdown under the search box says "--All Device Types--". Should I be using a different search phrase maybe? Sorry, but I couldn't find online any instructions on how to do this, so I thought I'd try to ask in this new forum.

I've also attached a screenshot of what I see in the ComposerPro search. Appreciate your help.

 

 

Screen Shot 2016-03-09 at 9.57.01 AM.jpg

Link to comment
Share on other sites

????

Why in the world aren't you just searching for 'time warner'?

 

It's a search - not sure why it would seem so confusing? I can understand that you might try the 'cable' section, but as I stated a lot of these more advanced drivers are not based on these basic proxies.

Link to comment
Share on other sites

42 minutes ago, Cyknight said:

????

Why in the world aren't you just searching for 'time warner'?

 

It's a search - not sure why it would seem so confusing? I can understand that you might try the 'cable' section, but as I stated a lot of these more advanced drivers are not based on these basic proxies.

This is the first thing I've tried, of course. Searching for "time warner" brings back just "Cable Icons". Please see the attached screenshot below.

 

 

Screen Shot 2016-03-09 at 11.30.55 AM.jpg

Link to comment
Share on other sites

11 minutes ago, msgreenf said:

Search for time Warner or the model of the box. Nothing is different from adding a cable box to a media player. Drivers are drivers and connections are connections

Sent from my Nexus 9 using Tapatalk

That's what I would think. Not sure why I am having such a hard time with this. Per my post above, searching for "time warner" just brings back "cable icons" match only. Searching for the "dcx3200" model number gives me these 3 matches:

 

Screen Shot 2016-03-09 at 11.37.13 AM.jpg

Link to comment
Share on other sites

So, I grabbed that cable pack, there's documentation:

 

ICON PACK for TIME WARNER CABLE
This driver provides icons for Time Warner Cable boxes when combined with an OS 2.8.1 system.   You must use a cable driver from the Composer database which is denoted ‘Icon Ready’.
INSTRUCTIONS
BEFORE you add this driver to your project you must rename the driver file to my_cable_provider.c4z
Renaming the driver inside Composer will not work!
If you have not renamed this driver then:
1.    Delete the driver from your project
2.    Close Composer
3.    Rename the file on your computer to my_cable_provider.c4z
4.    Reopen Compser
5.    Add the driver back into the project
TROUBLESHOOTING
If you see no icon for the device then you have not correctly re-named this driver.
If you see the generic cable icon for the device then you have not used the correct style of cable driver.
If you see another cable provider icon then the Control4 system has already had a cable provider icon pack added.  You can remove this as follows:
1.    Delete this driver from the project
2.    Close Composer
3.    SSH into the controller
4.    Enter cd mnt/internal/c4z
5.    Enter rm -r my_cable_provider*
6.    Close the SSH connection
7.    Re-open Composer
8.    Re-add this driver to the project

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...