Jump to content
videostorm

C4 driver for nVidia Shield

Recommended Posts

53 minutes ago, videostorm said:

This was done in driver version 3.0.

@videostorm
Just to confirm: You were able to add the long press for select (enter) key to the free driver?

Awesome!

Share this post


Link to post
Share on other sites

1 hour ago, mallom said:

@videostorm
Just to confirm: You were able to add the long press for select (enter) key to the free driver?

Awesome!

Yes, but not by long press of the select key on the C4 remote (that doesn't work as expected).  It is an optional mapping for the color keys.

Share this post


Link to post
Share on other sites
6 minutes ago, videostorm said:

Yes, but not by long press of the select key on the C4 remote (that doesn't work as expected).  It is an optional mapping for the color keys.

Ohh.. so there is no way to bring the context menu via IRUSB? Example: You press and hold an application, and you can choose to Move, delete and etc.

Share this post


Link to post
Share on other sites
24 minutes ago, mallom said:

Ohh.. so there is no way to bring the context menu via IRUSB? Example: You press and hold an application, and you can choose to Move, delete and etc.

Just assign your "Red" button (via our IRUSB driver) to be "long select".   Then use the RED button instead of press/hold the select button.

Share this post


Link to post
Share on other sites
Just assign your "Red" button (via our IRUSB driver) to be "long select".   Then use the RED button instead of press/hold the select button.

Cool! I will try that. Thanks!

Share this post


Link to post
Share on other sites

The quick launch for the amazon fire version of movies anywhere is not the same as with Android - com.moviesanywhere.goo#Intent;component=com.moviesanywhere.goo/com.disney.brooklyn.tv.ui.main.TVMainActivity;end\r"

Anyone know how to capture the code from the fire tv?

Share this post


Link to post
Share on other sites
1 minute ago, msgreenf said:

yeah, now if i could only get adb to connect ;)

I also had that problem at the beginning but I can't remember the magic ingredient.  I'm sure someone will chime in before I can remember how I overcame that. 

Share this post


Link to post
Share on other sites

Resurrection time:

I'm on Shield Android TV version 7.2.3, I'm using version 3.3 of the VideoStorm driver, and on v224 firmware. In the driver I've assigned Netflix to Red, Hulu to Green, and Amazon Prime Video to Blue. Hulu and Amazon work, Netflix does not. However, the Netflix (Universal) miniapp from Control4 in the watch menu does work. Other than mapping the Red button to fire the universal miniapp while the Shield is the active video source, how can I get the Red button to activate Netflix with the VideoStorm driver properly?

Share this post


Link to post
Share on other sites
3 hours ago, icefloe01 said:

Resurrection time:

I'm on Shield Android TV version 7.2.3, I'm using version 3.3 of the VideoStorm driver, and on v224 firmware. In the driver I've assigned Netflix to Red, Hulu to Green, and Amazon Prime Video to Blue. Hulu and Amazon work, Netflix does not. However, the Netflix (Universal) miniapp from Control4 in the watch menu does work. Other than mapping the Red button to fire the universal miniapp while the Shield is the active video source, how can I get the Red button to activate Netflix with the VideoStorm driver properly?

The button bindings and the universal mini apps both use the same code launch table, so they should behave the same.  Did you try changing the red button property, click set, then change back to Netflix and click set?

Share this post


Link to post
Share on other sites
16 minutes ago, videostorm said:

The button bindings and the universal mini apps both use the same code launch table, so they should behave the same.  Did you try changing the red button property, click set, then change back to Netflix and click set?

Extra info: for C4 I'm on OS3. 

Yes, I did do that. I also tried setting the Yellow button to Netflix and it still didn't work. Just to rule a malfunction of the remote I did try it through programming to fire the miniapp driver and that does work. I just can't get it to work natively.

Share this post


Link to post
Share on other sites
39 minutes ago, videostorm said:

The button bindings and the universal mini apps both use the same code launch table, so they should behave the same.  Did you try changing the red button property, click set, then change back to Netflix and click set?

Grabbed some LUA output:

Timer Expired.  ID:  5227442
Send RS232 command (QGETPLAY
QGETPLAY
OK
0
Received from Proxy: PROGRAM_D; on Binding: 5001
Parameter: ROOM_ID; value: 16
Implement BLUE function...
Parameter: DEVICE_ID; value: 72
Timer Expired.  ID:  6022925
Send RS232 command (QLAUNCH android-app://com.amazon.amazonvideo.livingroom#Intent;component=com.amazon.amazonvideo.livingroom/com.amazon.ignition.IgnitionActivity;end
QLAUNCH android-app://com.amazon.amazonvideo.livingroom#Intent;component=com.amazon.amazonvideo.livingroom/com.amazon.ignition.IgnitionActivity;end
OK
Timer Expired.  ID:  5227442
Send RS232 command (QGETPLAY
QGETPLAY
OK
0
Timer Expired.  ID:  5227442
Send RS232 command (QGETPLAY
QGETPLAY
OK
0
Timer Expired.  ID:  5227442
Send RS232 command (QGETPLAY
QGETPLAY
OK
0
Received from Proxy: GUIDE; on Binding: 5001
Parameter: DEVICE_ID; value: 72
Send RS232 command (QHIDCODE2002035
QHIDCODE2002035
OK
Parameter: ROOM_ID; value: 16
Timer Expired.  ID:  5227442
Send RS232 command (QGETPLAY
QGETPLAY
OK
0
Timer Expired.  ID:  5227442
Send RS232 command (QGETPLAY
QGETPLAY
OK
0
Received from Proxy: PROGRAM_A; on Binding: 5001
Parameter: ROOM_ID; value: 16
Parameter: DEVICE_ID; value: 72
Implement RED function...
Timer Expired.  ID:  5227442
Send RS232 command (QGETPLAY
QGETPLAY
OK
0
Timer Expired.  ID:  5227442
Send RS232 command (QGETPLAY
QGETPLAY
OK
0
 

Share this post


Link to post
Share on other sites
3 hours ago, videostorm said:

Thanks for the log.  Looks like the property for Netflix had an issue.  Fixed now in driver version 3.4 on our website.

Cool, thank you. Just remotely updated, will try it when I get home.

Share this post


Link to post
Share on other sites
On 7/1/2019 at 3:24 PM, icefloe01 said:

Cool, thank you. Just remotely updated, will try it when I get home.

Crud, forgot to reply, apologies. That fixed it!

Thank you.

Share this post


Link to post
Share on other sites

Another question: do I now choose Google Play or Google Play TV? I'm currently using GPTV and it seems to be working okay, I'm just curious if one is more correct than the other.

 

Eric

Share this post


Link to post
Share on other sites
13 hours ago, icefloe01 said:

Another question: do I now choose Google Play or Google Play TV? I'm currently using GPTV and it seems to be working okay, I'm just curious if one is more correct than the other.

 

Eric

Android TV => Google Play TV setting    (Shield, Sony TV, etc)

Plain Android => Google Play setting (most phones, tablets, cheap streaming boxes, etc)

Fire OS =>  Amazon setting  (all Amazon devices)

 

It just affects the app launch urls.  Developers sometimes have to publish different app names to different app stores.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...