Jump to content
videostorm

C4 driver for nVidia Shield

Recommended Posts

GregC, that is awesome, i was just going to ask someone to make that!!  Thank you.

Do you think you could make 2 other mini-drivers for this shield for me?  (I have the Qlaunch URLs already, i just want the drivers with the right icons)?

Share this post


Link to post
Share on other sites

PBS kids - org.pbskids.video#Intent;component=org.pbskids.video/.activities.LogoActivity;end

Unifi Protect - com.ubnt.unifi.protect#Intent;component=com.ubnt.activities.timelapse.CameraActivity;end

 

Thank you!!

Share this post


Link to post
Share on other sites

Here ya go. Give these a try

your qlaunch for PBS kids didn't work on my up-to-date system so i changed it to:

QLAUNCH android-app://org.pbskids.video#Intent;component=org.pbskids.video/.splash.ui.SplashScreenActivity;end

You can always adjust to whatever you want on the Properties page in the System Design view of Composer

shield_pbs_kids.c4z shield_unifi_protect.c4z

Share this post


Link to post
Share on other sites

Wow,

thank you very much, I appreciate it.  That Qlaunch works for me, do you happen to have a 2019 pro shield with 8.1 on it?  I only have a 2017 with 8.01, so perhaps that is the difference?  either way, THANK YOU!!

Share this post


Link to post
Share on other sites
5 hours ago, GregC said:

Here ya go. Give these a try

your qlaunch for PBS kids didn't work on my up-to-date system so i changed it to:

QLAUNCH android-app://org.pbskids.video#Intent;component=org.pbskids.video/.splash.ui.SplashScreenActivity;end

You can always adjust to whatever you want on the Properties page in the System Design view of Composer

shield_pbs_kids.c4z 413.71 kB · 2 downloads shield_unifi_protect.c4z 878.83 kB · 2 downloads

My dealer tried to install install these for my shield, but apparently they don't have the correct connection binding type, these are RF_AMAZON_FIRE_APP and not the RF_IRUSB_APP for the nvidia shield. 

Share this post


Link to post
Share on other sites
11 hours ago, shupp872 said:

My dealer tried to install install these for my shield, but apparently they don't have the correct connection binding type, these are RF_AMAZON_FIRE_APP and not the RF_IRUSB_APP for the nvidia shield. 

Nevermind, I think i was able to go in an edit the xml to make the driver work.  Thank you!

Share this post


Link to post
Share on other sites

Hello all,

We will have a new firmware version for IRUSB later this week.  Looking for some volunteers to try it out...

IRUSB firmware V225 should eliminate the current need for hard reboots when device OS updates happen.

With V225:

       (existing) Hard boot:  IRUSB will auto launch and connect after 4 minutes

       (new) Soft boot, OS update, any other disconnect:  IRUSB will auto launch and connect after 11 minutes

 

Just PM me if you want early access to this version.  Thanks!

Share this post


Link to post
Share on other sites
29 minutes ago, videostorm said:

Hello all,

We will have a new firmware version for IRUSB later this week.  Looking for some volunteers to try it out...

IRUSB firmware V225 should eliminate the current need for hard reboots when device OS updates happen.

With V225:

       (existing) Hard boot:  IRUSB will auto launch and connect after 4 minutes

       (new) Soft boot, OS update, any other disconnect:  IRUSB will auto launch and connect after 11 minutes

 

Just PM me if you want early access to this version.  Thanks!

I used to have issues with the Amazon Fire TV - every so often it would loose IRUSB connection and I'd have to manually launch the IRUSB app.  I had auto updates on the Fire TV turned off. After these issues I moved on but I kept the hardware.  Would this fix those issues?

Share this post


Link to post
Share on other sites
23 minutes ago, eggzlot said:

I used to have issues with the Amazon Fire TV - every so often it would loose IRUSB connection and I'd have to manually launch the IRUSB app.  I had auto updates on the Fire TV turned off. After these issues I moved on but I kept the hardware.  Would this fix those issues?

Yes, it should. 

Share this post


Link to post
Share on other sites
5 hours ago, videostorm said:

Hello all,

We will have a new firmware version for IRUSB later this week.  Looking for some volunteers to try it out...

IRUSB firmware V225 should eliminate the current need for hard reboots when device OS updates happen.

With V225:

       (existing) Hard boot:  IRUSB will auto launch and connect after 4 minutes

       (new) Soft boot, OS update, any other disconnect:  IRUSB will auto launch and connect after 11 minutes

 

Just PM me if you want early access to this version.  Thanks!

I'm not familiar with how Android handles starting/running apps, but I'm curious if there is a way to load IRUSB either as a service or in the background without actually opening the app. That way the user doesn't have to exit the the interface to use the Shield.

Share this post


Link to post
Share on other sites
2 hours ago, icefloe01 said:

I'm not familiar with how Android handles starting/running apps, but I'm curious if there is a way to load IRUSB either as a service or in the background without actually opening the app. That way the user doesn't have to exit the the interface to use the Shield.

IRUSB has to load an activity to the foreground (because of the USB permissions).  Other types of apps (such as NetPlayTV), can "silently" load.

It's a security "feature" of the OS.

Share this post


Link to post
Share on other sites
10 hours ago, videostorm said:

Hello all,

We will have a new firmware version for IRUSB later this week.  Looking for some volunteers to try it out...

IRUSB firmware V225 should eliminate the current need for hard reboots when device OS updates happen.

With V225:

       (existing) Hard boot:  IRUSB will auto launch and connect after 4 minutes

       (new) Soft boot, OS update, any other disconnect:  IRUSB will auto launch and connect after 11 minutes

 

Just PM me if you want early access to this version.  Thanks!

Does this mean it now takes longer for the Irusb to connect after a reboot?

Share this post


Link to post
Share on other sites
9 hours ago, digitaltrader said:

Does this mean it now takes longer for the Irusb to connect after a reboot?

No, the time after a hard power cycle is the same (~4 minutes).  On some devices, a "reboot" is equivalent to a hard power cycle.  On other device (like the Fire sticks), a "reboot" it is more like a device reset.  On firmware 224 or lower, the later case would require you to manually pull the plug.  On 225, it should also automatically reconnect in the later case but takes about 11 minutes.

Share this post


Link to post
Share on other sites

Just got a NEO remote to test. highly recommend.

anyway, there appears to be a bug in the Shield driver where clicking on the Shield does not bring back navigation.

I made a video to illustrate: https://photos.app.goo.gl/oG1GvZJ3C2gETCPs5

videostorm, if this is not a driver specific bug but rather a C4 bug please let me know and I'll send to them.

 

thanks!

Share this post


Link to post
Share on other sites
18 minutes ago, GregC said:

Just got a NEO remote to test. highly recommend.

anyway, there appears to be a bug in the Shield driver where clicking on the Shield does not bring back navigation.

I made a video to illustrate: https://photos.app.goo.gl/oG1GvZJ3C2gETCPs5

videostorm, if this is not a driver specific bug but rather a C4 bug please let me know and I'll send to them.

 

thanks!

Can you send us the IRUSB driver lua log (set debug mode to print) of pressing the "shield" button?  

If nothing is added to the log when you press that button then it is definitely a C4 issue.  Otherwise we should be able to see in the log what is going on.

Share this post


Link to post
Share on other sites

I'll be able to test out your scenario this weekend too.  I have a shield as well and just received my demo Neeo.  I'll report back what I find.

Have to update to 3.0 first though after changing out some hardware I've been running for years.

Share this post


Link to post
Share on other sites

videostorm,

this entry just keeps repeating. There are no other entries when I press Shield on the remote

 

Quote

 

Timer Expired.  ID:  189654723

Send RS232 command (QGETPLAY

QGETPLAY

OK

0

LUA_ERROR [id: 1400][name: Universal Android Driver][file: mediaplayer_android_irusb.c4z][method: ReceivedFromNetwork]: [string "Lua Code"]:757: attempt to compare number with nil

 

 

Share this post


Link to post
Share on other sites
5 minutes ago, GregC said:

videostorm,

this entry just keeps repeating. There are no other entries when I press Shield on the remote

 

 

That is the polling for play status.  The error isn't relevant.  Since there are no proxy commands when you are pressing that button, it must be a C4 issue.

Share this post


Link to post
Share on other sites

I contacted C4. they asked me to try some other video sources. I added the Apple TV and Directv drivers. Both of those worked as expected. They think it's a driver issue. Not sure where to go from here

Share this post


Link to post
Share on other sites

I kept adding drivers and there are quite a few that don't work as expected, so it's not just your driver.

I contacted C4 again to let them know. Hopefully they have an answer soon.

thanks

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...