Jump to content
pinkoos

IP Cameras timestamp not sticking

Recommended Posts

Lilin cameras connected to a Zuum NVR

The timestamp coming from the NVR is correct

However, the timestamp (which is stamped on the camera feeds) is not correct

We've gone into each cam's configuration page and tried both the options of syncing the time with PC and syncing the time with an NTP server

Works for a few hours and then the time messes up again (off by 5 to 6 hours usually)

We're at a loss of what is going on

This all started after DST here in the US

Share this post


Link to post
Share on other sites

Go to advanced/system/timer and set the timezone and daylight savings time settings. Ensure you have a good ntp timeserver and that the cameras can reach it. Be sure to tick the radio button for sync every hour.

Share this post


Link to post
Share on other sites
On 3/19/2019 at 12:39 PM, Matt Lowe said:

might try a new dns server like 8.8.8.8

also if they will let you change ntp server might try a new one there too

Where do I change the DNS server?

I changed the NTP server from time.nist.gov to us.pool.ntp.org - it worked for maybe half a day or so and then the time messed up again

For example, it's 6:34 AM right now, but the cams are showing 11:34 AM

Really frustrating issue as we finally got cams that work with our touchscreens, Navigator and NVR but now this problem has cropped up

The timestamps are important since if we ever need to use footage for any kind of proof of something happening, having the wrong time printed directly on the video will undermine anything we're trying to prove

Share this post


Link to post
Share on other sites
7 hours ago, pinkoos said:

having the wrong time printed directly on the video will undermine anything we're trying to prove

I think this comes from watching too many movies. If you have a bandit assault you and smiles nice for the camera I think the judge is going to maybe be understanding of your timestamp issue on your residential cameras. You are actually better off not having the timestamp. The NVR is probably properly marking the time on the track.

 

7 hours ago, pinkoos said:

Where do I change the DNS server?

I'm guessing you probably have access to the manual and the google. Basic>network>general

Share this post


Link to post
Share on other sites
On 3/19/2019 at 12:39 PM, Matt Lowe said:

might try a new dns server like 8.8.8.8

also if they will let you change ntp server might try a new one there too

Changed to 8.8.8.8, no luck

Also had changed the server to the ntp pool one mentioned above, again no luck

Share this post


Link to post
Share on other sites

I updated the firmware for all 4 cams, reboot them and reset the timestamps, but the problem is still there

All 4 of them seem to add about 5 to 6 hours around the same time of day, between noon and 2 PM

For example, I checked them about 45 mins ago or so (maybe 1:15 PM local time) and they were fine

Just checked again (around 2 PM local time) and they all say it's about 7 PM local time

Share this post


Link to post
Share on other sites

There are two options for my time zone in the cam settings:  Central standard and another one that lists a few cities, including Houston.

Both of those are -600 GMT (or something like that)

And I've checked off Daylight Savings time as well

Regardless, I've switched back and forth between the two choices, had DST checked on and off, tried turning off NTP server sync and just syncing to PC, but nothing sticks for more than 12 to 18 hours

It's crazy

Share this post


Link to post
Share on other sites
After much research and googling online the last week or two I came across a single post on an IP cam forum that mentioned a similar problem and the following potential solution:
 
In the NVR’s System->General settings pane, there is an option to check or uncheck “IPC Time Sync”
 
It had been checked all this time, so I unchecked it very early yesterday morning and, so far, the cams’ timestamps have not messed up.
 
They usually mess up sometime between noon and 2 PM, so the fact that they haven’t messed up since I changed the setting early yesterday morning is a good sign.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...