Jump to content
Shivam Paw

DS2 Misc Commands Driver

Recommended Posts

Hi,

Here is a quick driver that has a few commands you can use for your DS2 programmatically.

The current commands that can be run are:

  • Enable Day Mode
  • Enable Night Mode
  • Disable Camera API Auth
  • Set Camera Brightness
  • Set Camera Saturation

Why? Well I've been having issues (and some others have as well) with the DS2 not working with "Auto" settings for day/night mode. So you can use this driver and C4 scheduler to set the day/night mode at sunrise and sunset.

You can also use the disable camera API auth command with the generic image url attachments driver and run the disable camera api auth command every time the project loads. Bit long winded, but it seems like the best option for now.

 

 

Change Log
Version 1
Initial Release

Version 2
Added set camera brightness/saturation

 

jooced_ds2_misc_commands.c4z

Share this post


Link to post
Share on other sites

Thanks.  I have just been playing with the “first” version of your driver and it is great.  I have been tweaking my settings (brightness, colour saturation and infrared) to get the best possible picture.  What had crossed my mind was that the best settings in day time could be different, so it would be nice to be able to change these programmatically (infrared is probably not necessary!).

The other item that was an issue a while back (and May have been fixed with a driver / firmware or OS update) is that my camera said it was defaulting to “Outdoor” but was actually defaulting to Outdoor highlight compensation so I needed to change it every time I rebooted.  I am still doing this (May be unnecessary now).  Thus, a programmatic command to change the camera mode would also be nice... may also be useful in certain lighting situations to change this between day and night...

Nothing vital here... so more importantly - thanks again! Great driver

Share this post


Link to post
Share on other sites
2 hours ago, South Africa C4 user said:

Thanks.  I have just been playing with the “first” version of your driver and it is great.  I have been tweaking my settings (brightness, colour saturation and infrared) to get the best possible picture.  What had crossed my mind was that the best settings in day time could be different, so it would be nice to be able to change these programmatically (infrared is probably not necessary!).

The other item that was an issue a while back (and May have been fixed with a driver / firmware or OS update) is that my camera said it was defaulting to “Outdoor” but was actually defaulting to Outdoor highlight compensation so I needed to change it every time I rebooted.  I am still doing this (May be unnecessary now).  Thus, a programmatic command to change the camera mode would also be nice... may also be useful in certain lighting situations to change this between day and night...

Nothing vital here... so more importantly - thanks again! Great driver

V2 :)

I'm hesitant to add the camera mode functionality at the moment because of how the DS2 driver won't update through camera setting changes but will look into it as I agree, could be helpful!

jooced_ds2_misc_commands.c4z

Share this post


Link to post
Share on other sites

Must say, I am loving this and have got all of the commands working and am using all of them as I now have a slightly different brightness and colour saturation setting for day time (cf night time).  All in all, a big improvement!

I have also got the camera (disable) authentication working although for some reason I can’t get the generic url driver to work and include a picture in the push notification.  I am probably doing something really stupid and will try again one evening this week.

Thanks again! Great driver,

Share this post


Link to post
Share on other sites
4 hours ago, South Africa C4 user said:

Must say, I am loving this and have got all of the commands working and am using all of them as I now have a slightly different brightness and colour saturation setting for day time (cf night time).  All in all, a big improvement!

I have also got the camera (disable) authentication working although for some reason I can’t get the generic url driver to work and include a picture in the push notification.  I am probably doing something really stupid and will try again one evening this week.

Thanks again! Great driver,

What URL are you using and does it work when you visit it in incognito?

Share this post


Link to post
Share on other sites
22 hours ago, Shivam Paw said:

What URL are you using and does it work when you visit it in incognito?

I’m using the URL you provide in the driver documentation for the DS2 (inserting the correct IP address) for retrieving a snapshot once authentication is turned off.  I copied the URL into a web browser and it works perfectly there.  If I have not turned off the authentication requirement, it asks for a user name and password as expected.  Once I use your driver to turn off the authentication requirement, the URL posted into a web browser gives the screen shot perfectly. However, when I send a push notification, I don’t see any attachment... I can’t figure out what I am doing wrong 🙈

Share this post


Link to post
Share on other sites
Just now, South Africa C4 user said:

I’m using the URL you provide in the driver documentation for the DS2 (inserting the correct IP address) for retrieving a snapshot once authentication is turned off.  I copied the URL into a web browser and it works perfectly there.  If I have not turned off the authentication requirement, it asks for a user name and password as expected.  Once I use your driver to turn off the authentication requirement, the URL posted into a web browser gives the screen shot perfectly. However, when I send a push notification, I don’t see any attachment... I can’t figure out what I am doing wrong 🙈

You've gone to agents -> push notifications and set the attachment for that notification?

Share this post


Link to post
Share on other sites
On 6/10/2019 at 4:25 PM, South Africa C4 user said:

Big thanks to @Shivam Paw who picked up on my problem,  accessed my system remotely and solved the problem in 20 minutes.  I certainly cannot complain about the service on a free driver! 

What was the problem?

I am in the same situation that I can view the screenshot, but it doesnt attach to the push.

Share this post


Link to post
Share on other sites
7 minutes ago, juan15pablo said:

What was the problem?

I am in the same situation that I can view the screenshot, but it doesnt attach to the push.

Triple check your Camera API auth is set to None and try adding the port 80 to the url.

E.g. instead of http://10.0.1.61/api/camera/snapshot?width=640&height=480&source=internal try http://10.0.1.61:80/api/camera/snapshot?width=640&height=480&source=internal

Share this post


Link to post
Share on other sites
7 minutes ago, Gary Leeds UK said:

Having the same issue - Using no Port

Same issue as in a small image or no image? 

small image is how iOS shows notification images. You need to 3D Touch on the notification to enlarge. 

No image - try adding a port and checking that the camera api is set to none 

Share this post


Link to post
Share on other sites

Hi

Nice driver

I'm having an issue with now image showing up

Correct IP address for DS2. Can see image in browser with and without port so auth is off.

In push notification agent I've also added attachment but still no image at all in the notification

I'm sure its something simple but what am I missing?

Thanks

Share this post


Link to post
Share on other sites
14 minutes ago, Viking said:

Hi

Nice driver

I'm having an issue with now image showing up

Correct IP address for DS2. Can see image in browser with and without port so auth is off.

In push notification agent I've also added attachment but still no image at all in the notification

I'm sure its something simple but what am I missing?

Thanks

Is Auth definitely off? Can you check it in incognito?

Share this post


Link to post
Share on other sites
17 hours ago, Shivam Paw said:

Is Auth definitely off? Can you check it in incognito?

Hi

Thanks for the response. Yes can confirm it works in incognito mode but still not on iphone

Share this post


Link to post
Share on other sites

@Shivam Paw - does this driver still work on OS3.1? It stopped working for me when I upgraded, but I assumed that changing the password and username to root and whatever random password the DS2 now has (under OS3.1) would fix the problem but it still is not working for me.  I am hoping that I am doing something silly!

Share this post


Link to post
Share on other sites
6 minutes ago, South Africa C4 user said:

@Shivam Paw - does this driver still work on OS3.1? It stopped working for me when I upgraded, but I assumed that changing the password and username to root and whatever random password the DS2 now has (under OS3.1) would fix the problem but it still is not working for me.  I am hoping that I am doing something silly!

I just tested this on 3.1.1 and it worked for me. The default username and password however is what you use on the web interface - default username is admin and password is the normal on

Share this post


Link to post
Share on other sites
40 minutes ago, Shivam Paw said:

I just tested this on 3.1.1 and it worked for me. The default username and password however is what you use on the web interface - default username is admin and password is the normal on

Thanks... got it working using “admin” and the new automatically created strong password... I was using “root” instead of “admin”.

Unfortunately I seem to have totally stuffed up my second Doorstation when playing around with this... I did a factory reset and now that Doorstation is offline.  Apparently one needs to setup the HTTP API account1 credentials on the web interface after a factory reset now... I tried to do that but obviously got it wrong.  Definitely time for me to call my dealer tomorrow!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...