Jump to content
lax

Display temp from Card Access WCS10A Wireless Contact Relay

Recommended Posts

I'd like to display the temperature from my wine cellar on a T3 touch screen (under the comfort menu - sort of like a thermostat). I have a CardAccess WCS10A-2-ZP unit that can sense temperature, but I have no clue how to get it to display on the T3.... I have a Generic Temperature Display Driver installed too. 

The Temperature Display Driver (OS 2.10+) shows this

702088072_C4TemperatureDisplayDriver.thumb.png.477ed3f82622cce25068fdc1d10ec9d0.png

 

The CardAccess unit shows these connections

1421558955_C4WirelessSensor.thumb.png.1b4b106ad3062367fa1707713ef567ba.png

So there's no relevant bindings that can be made and I also didn't see anything in programming that could accomplish this. 

Any ideas?

 

 

Share this post


Link to post
Share on other sites

@lax Try out this driver. I haven't tested it on a system running OS 2, but I believe it will still work. You will need to bind it to the temperature out bindings of the module. A (uncontrollable) thermostat will show up under the Comfort menu.

Also, I am a Control4 employee, but Control4 does not support or endorse this driver in anyway. Please use at your own risk. No is warranty implied or otherwise, etc..

TstatConnector.c4z

Share this post


Link to post
Share on other sites

Thank you for the driver. The issue appears to be getting the temperature off the CardAccess unit (WCS10A-2-ZP). It's available in variables, but was hoping there would be a binding that could be made between the CardAccess unit and the temperature display driver. The unit only has three bindings, all for contact_sensor. Seems I have to fiddle with variables and programming to maybe get this to work. 

Share this post


Link to post
Share on other sites
8 hours ago, lax said:

Thank you for the driver. The issue appears to be getting the temperature off the CardAccess unit (WCS10A-2-ZP). It's available in variables, but was hoping there would be a binding that could be made between the CardAccess unit and the temperature display driver. The unit only has three bindings, all for contact_sensor. Seems I have to fiddle with variables and programming to maybe get this to work. 

You can make bindings with the Z2IO and the newer C4 Temperature Display driver but this does not work with the Cardaccess unit.  You have to do programming with the variables and the custom temperature display driver (Yatun).  I can't speak for the driver above that was posted but the programming method works with Yatun's driver.

Share this post


Link to post
Share on other sites

I figured out how to do this using the older Card Access driver (from 2009) for the WCS10A-2-ZP and not the newer one labeled Control4 (from 2015).

image.png.e7149d52716102582f103a01e5809f3e.png

Then, to display the temperature, I used this driver (also from Card Access)

image.png.08a4b701a052f62d3e9f7097fc910bac.png

That Thermostat Display driver allows you to select a Source Device under the properties and voila, the temp shows up. However, if you use the Control4 driver for the WCS10A-2-ZP, then the source device won't show up as a selectable device.

image.thumb.png.127a185346d50feab4273b1cf3d24ea4.png

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...