Jump to content
bmrowe

C4-Therm help

Recommended Posts

Just got a C4-Therm and installed it. Controlling the hvac fine, but can't get it to join my existing control4 network (with two existing c4-therm thermostats). Following instructions copied below, but thermostat saying 'not joined to network'. I checked our bedroom thermostat, which was installed 2+ years ago and its on a different channel. Not sure if that matters. but thought it was worth including. I'm super new to zigbee networking, so feeling a bit lost as how to troubleshoot.

zigbee.png

therm.jpg

Share this post


Link to post
Share on other sites

Have you tired the 13 - 4 - 13 button reset?

And then tried to add it to your system?

Do you know if your zigbee mesh is getting to where the stat is ? Do you have any other zigbee devices in that area?

Are you using the correct driver?

Thanks
M


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
13 minutes ago, mujtaba.khokhar said:

Have you tired the 13 - 4 - 13 button reset?

And then tried to add it to your system?

Do you know if your zigbee mesh is getting to where the stat is ? Do you have any other zigbee devices in that area?

Are you using the correct driver?

Thanks
M


Sent from my iPhone using Tapatalk

Hey M -

 

Thanks for the quick reply! I did do the 13-4-13 reset but its pretty hard to tell if it stuck. I think it did because the thermostat went from saying 'no signal' to 'not joined to network'.

There is a wall switch on the opposite side of the hallway (like 3 feet away) -- see picture. I assume these wall switches are on zigbee, but again I'm learning a lot. 

Finally, I'm not a C4 dealer, so I don't have access to Composer. Can I 'add it to my system' via the app/website or composer HE? I sorta dread calling my dealer since its a multi-day turnaround. I was hoping it would join the network and then I could call them to add it as another 'comfort' option like my other two thermostats.

Thanks again!

 

 

switch.jpg

Share this post


Link to post
Share on other sites

Unfortunately that’s not how it works.

The dealer has to have a certain window open for the thermostat to identify into the system.

If you like PM me and I can sort this out for you right now

Thanks
M


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...