Jump to content

Pentair IntelliCenter


Recommended Posts


I have not yet but I am really curious on how it works, as I have a client just a week ago asking to integrate there pool with c4. Can you let us know how it went and how the integration went. User/customer experience, was it easier to add to c4.... you know, the usual things.
Thank you in advance

Sent from my SM-G986U using Tapatalk

Link to post
Share on other sites

It seemed to be quick as far as adding it to the system. The driver populated everything attached to my IntelliCenter. The issue is that some of the items seem to have two way feedback and some just never follow real time on/off. The pool temperature, heater and pump seem to update between both controllers. The water feature zones do not. Usually the C4 app is showing completely different status. I’m just wondering if there is something wrong on my end. I’d really like for it to work so I don’t have to go to multiple apps to control everything. And it will be helpful when constructing scenes. 

Link to post
Share on other sites

I have it, and it seems to sync up states, however I do see some bizarre things here and there.  For example, if I turn off a water feature (slide) from C4, sometimes the slide will go On / Off / On / Off / On / Off / On / Off (over and over for a minute or two) - this doesn't happen, but when it does, it makes you wonder what's happening.  When this is happening, you can see the slider on the touchscreen going back and forth on it's own...  I've also seen the same thing with the lights, where the lights will turn on, you'll change the color using C4 on the touchscreen, and the lights will turn off (when this happens I think that it's just the intellicenter adjusting the color, because it works by cycling the circuit x number of times to tell the lights what colors to use, and while doing this the lights remain off), however they will stay off indefinitely.

I rarely turn things on via the IntelliCenter itself, we almost exclusively use a touchscreen that's near the patio.

Link to post
Share on other sites

My experience is similar but I’d really like it to work so I can assign some keypads to each feature. 
 

1. The pump status, temperature abs heater seen to always be correct. 
 

2. If I turn on the deck keys from the C4 app, they will indeed turn on (as long as the deck keys are in the off position when I open the C4 app) but if I set my phone down and the app shuts off, the state will be changed back to off when I open the C4 app again. I’ve tried toggling back on and then off to get it to respond but it will not. 

Link to post
Share on other sites

Also found quite a few bugs with the driver.  Including the above (sometimes) and if you have multiple panels (daughter panels) and a complex setup, it does not bring all of the lights and circuits through to C4.  My dealer has an open ticket with C4 and a promise that they will get to working on the bugs he reported.

By far the biggest miss is that you can not view and (more importantly) change the vacation setting from C4.

I also use the Intellicenter App most of the time.

Other, more significant shortfalls include limited pump control, no way of controlling colour of colour changing lights, no feedback of pump information (rpm, kWh, gpm etc.)

Link to post
Share on other sites
2 hours ago, Olichops said:

I have this setup also and have experienced the same issues as others above. I wish there was the ability to access the Aux relays in C4 so it could be scheduled in C4 as part of the lighting control!

Make a Lighting Group on the Intellicenter. These seem to pull through fairly reliably to the C4 driver.

Link to post
Share on other sites

Lighting group in the intellicenter, you mean the outdoor control box or the intellitouch LCD panel which I don’t have. I do have the ScreenLogic adapter which I set the relay to a light but that does not pull tru to the C4 adapter to the C4 Touchscreens

 

Link to post
Share on other sites
1 hour ago, Olichops said:

Lighting group in the intellicenter, you mean the outdoor control box or the intellitouch LCD panel which I don’t have. I do have the ScreenLogic adapter which I set the relay to a light but that does not pull tru to the C4 adapter to the C4 Touchscreens

 

Screen Logic is not Intellicenter.  ScreenLogic is IntelliTouch.  A different Pentair control system.  Confusing names - I know!

The auxiliary relays work perfectly using the free IntelliTouch driver.  Although they only work for one way control. I believe that the paid for IntelliTouch driver had numerous issues.

You can ignore my comment on Lighting Groups as that relates to IntelliCenter. 

Link to post
Share on other sites

I had planned on putting a few keypads up to control the basic water features but I think it would be more frustrating than convenient. As of now, the pump, heater and water temp are still always correct. I’m not sure how they can get a few things correct.


Sent from my iPhone using Tapatalk

Link to post
Share on other sites
On 9/28/2020 at 3:30 AM, Olichops said:

I have this setup also and have experienced the same issues as others above. I wish there was the ability to access the Aux relays in C4 so it could be scheduled in C4 as part of the lighting control!

The above can be done on Control4 using the native IntelliTouch driver.

The below cannot.

17 hours ago, Olichops said:

Yep, I was looking for 2 way control so that Spa Controllers could activate lights on control 4 by unused aux ports of the Intellitouch

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...