Jump to content
c4forums | The Control4 Community

Problem with Volume and volume slider on ios app


Recommended Posts

I’m using the most recent ios app on an iphone Pro 12. C4 is v 3.2.1. 

Erratic behavior just started today  I’ve not noticed it ever before  

 
Ex:  
 
the volume  slider will read 40 on the app. I slide the volume up to 53 or tap it up in increments. 
 
Within 1-2 seconds later the slider snaps right back to 40 BUT the audible volume level stays at the new setting of 53. 
 
Then, the second i again move the slider up one notch or more, to something like 58, the audible volume instantly lowers back to 40. Then responding slowly To the increase, the audible volume level will go back up to the new setting of 58 within seconds but the slider will snap back to read 40. Then 10-20 minutes or more volume level reading  may be correct.
 
I have no clue why this would happen. I unplugged and rebooted both the c4 controller and repeater. I also rebooted the whole system with no improvement. 
 
Has anyone ever seen this behavior before?
Link to post
Share on other sites

After rebooting the Datasat it continues with the odd behavior. When I turn up the volume on the Datasat via c4 the Datasat respinds appropriately to the correct db. The audio output level and the db reading on the Datasat remains stable. It is only the c4 level reading that snaps back to the previous output reading but the drop does not impact the Datasat. Only when i increase or decrease the c4 setting, even by just one point, the output level on the Datasat will immediately drop back to the output level where the c4 dropped back to. 
 

Therefore my assumption is that it’s c4 causing the issue and not the Datasat. But I could easily be wrong!

 

Link to post
Share on other sites

 

Sounds like the 2-way communication isn't working - problem is, that doesn't tell you where the issue is: It could still be the C4 driver (won't be the 'system' as such) could be the connection (be it a serial cable network cable or overall network issue somewhere) or it could be the Datasat (not communicating out) itself.....

 

The reason the data set goes to a lower level as you describe on a C4 change is that because even on a small increase/decrease the system will send the % it wants the datasat to go to, and if it assumes the setting is currently 40%, a 1% increase will just mean the system sends the info to the datasat to got to 41% (as opposed to sending 'go up 1%')

Link to post
Share on other sites

I have 3 systems that exhibit this exact odd behaviour when using iOS 

When on a control screen the volume snaps back but when on the Home Screen and a volume adjustment is made the volume slider works properly

Don’t mind the sloppy navigator... it was a quick temp setup in my own system to replicate the issue

 

Link to post
Share on other sites

Have also seen this start on several devices in last 4 or 5 days.  SR260 works perfectly fine but IOS displays the behavior described above when controlling volume via an Anthem MRX720 and on a Triad Matrix. 

 

 

Link to post
Share on other sites

Interesting... I am seeing the exact same behaviour on my iPad (all watch devices - haven’t tried listen yet) if I choose the device itself and control the volume from within the proxy with the full remote control on the screen.  I don’t have the same problem if I control the volume from within the session view or from an SR260/250 or Neo remote... 

Looks like a bug to me... I just don’t know how long the bug has been around as I literally never control volume in this way (I did yesterday because I got to my beach house to find that some twit - probably me - had left the SR260 off the charging station in our main bedroom TV lounge a few weeks ago and the battery was dead...).

Link to post
Share on other sites

Yea...this is definitely a new problem. I can't think of any other reason than a bug in the app but I have no idea. This is a new problem for me and is a pain. I now do not know what the actual volume level is. It does finally correct itself but I have no idea how long it takes. Last night I watched a two hour film and near the end of the movie I did notice that the app displayed the correct percentage. I should look more closely next movie but who wants to be distracted from a good moving to watch this?!

 

How can we get c4 to look at this and get a response from them?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...