Jump to content
C4 Forums | Control4

Kwikset Lock - swapping Zwave/C4 cards


eggzlot
 Share

Recommended Posts

So in the past I've seen people selling C4 cards to make the regular Smartcode/Zwave Kwikset locks c4 compatible which makes me think these cards can easily pop in/out?

I have a 910 traditional C4 deadbolt but want to switch to the 910 contemporary one. the thing is, my 910 is just fine, but the finish is fading and I've changed the other door hardware so want the contemporary one on there to freshen it all up. 

Anything stopping me from going to Home Depot/Amazon etc and sourcing the Zwave Smartcode version, removing the Zwave card, and then removing my C4 card off my Traditional one and putting it into the new unit?

Link to comment
Share on other sites


I have done what you are talking about with Yale locks with out issue. Not sure about kwikset. I know Control4 use to sell the zgibee cards for kwikset but currently you cant buy them due to them switching to only snap selling 3rd party hardware. Buy it from amazon if you run into any issues just file a return. I would suggest you have the existing one leave the zigbee mesh prior to swapping the cards and record any saved codes.

Link to comment
Share on other sites

Yes you can just move the card over from your current lock to the zwave one and replace the zwave card, should work fine.  For some reason Control4 is no longer selling the contemporary one in Bronze.

Link to comment
Share on other sites

10 minutes ago, chopedogg88 said:

Yes you can just move the card over from your current lock to the zwave one and replace the zwave card, should work fine.  For some reason Control4 is no longer selling the contemporary one in Bronze.

Could I get the 916 model and swap cards? Or does it have to be an even 910 to 910 swap?

https://www.homedepot.com/p/Kwikset-Z-Wave-SmartCode-916-Touchscreen-Contemporary-Single-Cylinder-Venetian-Bronze-Keypad-Electronic-Deadbolt-with-SmartKey-916CNTTSCR11PZW/302238837

Link to comment
Share on other sites

I can't guarantee it will work but it probably will. Worst case return the one to home depot. Also you don't even need to buy the zwave version, I've put the c4 card into a dumb kwikset obsidian with no card and it worked fine. 

Link to comment
Share on other sites

Posted (edited)
10 minutes ago, chopedogg88 said:

I can't guarantee it will work but it probably will. Worst case return the one to home depot. Also you don't even need to buy the zwave version, I've put the c4 card into a dumb kwikset obsidian with no card and it worked fine. 

interesting

so anything here would work?

https://www.kwikset.com/products/deadbolts/keyless-entry-deadbolts

the more I look the more I realize the 916 comes in Zwave and Zigbee (I know not C4 Zigbee) but  the Zigbee one is like $30 cheaper.  the 915 is only $180 as well so cheaper than the Zwave (~$230) or the Zigbee (~$205).

Edited by eggzlot
Link to comment
Share on other sites

3 minutes ago, chopedogg88 said:

I can't guarantee that.  I just know that I bought a non-zwave Obsidian on Amazon recently, added the Control4 card, and it worked.

I got a 915 coming and a 916

ill try the 915 first

Link to comment
Share on other sites

On 6/29/2022 at 12:58 PM, chopedogg88 said:

I can't guarantee that.  I just know that I bought a non-zwave Obsidian on Amazon recently, added the Control4 card, and it worked.

Hey Ari

Working with the 915 as it has the slot, just with a dummy plastic card in there instead of the Zwave card.

On my C4 Navigator the door lock is the right status (open / closed) with the right time stamps, I can open/close the door by clicking the icon in c4 navigator, but my ~10 unique user codes from c4 do not seem to be working. Any ideas?

Link to comment
Share on other sites

On 7/3/2022 at 1:21 AM, chopedogg88 said:

try pressing the sync user codes to lock button in the driver actions?

Yeah I did that

Had a really old version of the driver, got it updated to the latest, added all the users back in, but still nothing.  

I don’t know why but I remember 10 years ago when installing these locks my old dealer told me you still needed a user code without c4 directly on the lock.  So I just manually created a user code directly on the lock too.

Still nothing.  Again everything else works in c4, just not the user codes…

Link to comment
Share on other sites

So to add - I created a lock manually on the door - my old codes in c4 still didnt work

that said I did notice in Composer HE that the driver says last unlocked by user 4. So user 4 for me is a blank spot (an old dog walker we dont use anymore so I had it as inactive). My guess is adding the code to the door manually took the first available slot - #4.

but when I long press the lock icon in Navigator and open it up the user code associated with User 4 is clearly not the code I entered on the door lock.

 

Link to comment
Share on other sites

As it's a new lock, you may have to end up removing it form C4, and reinstalling from scratch (and yes that means losing the codes.

Could start by trying to add a new lock driver, connect it, see if you can manage codes, then sync codes from old lock to new lock instead - that could at least save re-entering the codes if it works.

Link to comment
Share on other sites

To be clear - I think I had the same issue when I replaced a worn-out kwikset lock with a new one (smart lock but no card one bought locally, same basic model) and used the old card - I couldn't get codes to go direct, but when I used a second lock that I had that had the same codes, I could add a new driver, then force the codes from the other lock to the new one.

Link to comment
Share on other sites

24 minutes ago, Cyknight said:

To be clear - I think I had the same issue when I replaced a worn-out kwikset lock with a new one (smart lock but no card one bought locally, same basic model) and used the old card - I couldn't get codes to go direct, but when I used a second lock that I had that had the same codes, I could add a new driver, then force the codes from the other lock to the new one.

Was removed and re’ID’ but that didnt work.

I have 2 other kwikset locks installed on doors, and also the one I removed, so I have 3 other sets of hardware handy.  That said, we had the c4 card in the hardware set that was off the door (the older hardware), added the new driver, etc.

Now I cannot recall if I added the user codes while it was in the new set of hardware, or in the old hardware….but I did re-add the user codes, and I did get the c4 card into the new hardware and did a “sync all codes” or something along those lines.

I guess remove/delete the card again, put it into the original hardware (Again still works, just faded/bubbling and doesnt match the rest of the hardware), re-ID it, add all the codes, etc, then move it to the new hardware?

Link to comment
Share on other sites

20 hours ago, Cyknight said:

Could be a limitation of the lock then - not sure.

I have an email to Kwikset support - I left off C4 because they would likely say ask a dealer/C4...so I said I have the 916 Zwave and need to change color/finish and go from Traditional to Contemporary, so can I just buy the 915 and pop in my 916 card.  If they say yes, in theory what I am doing should work.  If they say no the device still needs to be "home connect" compatible maybe there is something different on the guts of the 915 vs the 916 other than the included Zwave/Zigbee/c4 Zigbee card.  the 915 has the slot for the card and as mentioned, everything but user codes work.

I guess I'll wait on their response.

Link to comment
Share on other sites

The issue is with the firmware of the card. If you use an old card it won’t support the newer locks that have 10 digit keypads vs 5 digit keypad. Is your card red or yellow?

I have the newer firmware cards that support both five digit and 10 digit locks. 

Link to comment
Share on other sites

7 hours ago, DanITman said:

The issue is with the firmware of the card. If you use an old card it won’t support the newer locks that have 10 digit keypads vs 5 digit keypad. Is your card red or yellow?

I have the newer firmware cards that support both five digit and 10 digit locks. 

Ah I have a red card and it is coming off a device with 5 buttons and not 10 buttons

Link to comment
Share on other sites

2 hours ago, eggzlot said:

Ah I have a red card and it is coming off a device with 5 buttons and not 10 buttons

That’s it. Red cards are the oldest and were out before the 10 button locks existed. They won’t support storing codes from 10 digit locks. 

Link to comment
Share on other sites

2 hours ago, DanITman said:

That’s it. Red cards are the oldest and were out before the 10 button locks existed. They won’t support storing codes from 10 digit locks. 

Many thanks!  At least the riddle is solved

Link to comment
Share on other sites

  • 4 weeks later...
On 7/9/2022 at 9:10 AM, DanITman said:

That’s it. Red cards are the oldest and were out before the 10 button locks existed. They won’t support storing codes from 10 digit locks. 

so for now we are going to keep the red card in our patio door.  We are the only ones that use it and really need minimal interaction with c4 so for now, it works

That said my wife liked the form factor of the 915/916 model, so I picked one up for the front door to replace our 910.  the 910 was purchased direct from C4, has the yellow C4 zigbee card, and has been working fine for 3+ years.

I popped the new 915 on the door, took the yellow card from the 910 and put it into the 915, but nothing, not working,  At least with the patio door (which has the red card) I can see when the lock is open/closed and program off those types of events, have it lock when I hit goodnight, etc.  

Any ideas if I am missing something simple?

Link to comment
Share on other sites

40 minutes ago, eggzlot said:

so for now we are going to keep the red card in our patio door.  We are the only ones that use it and really need minimal interaction with c4 so for now, it works

That said my wife liked the form factor of the 915/916 model, so I picked one up for the front door to replace our 910.  the 910 was purchased direct from C4, has the yellow C4 zigbee card, and has been working fine for 3+ years.

I popped the new 915 on the door, took the yellow card from the 910 and put it into the 915, but nothing, not working,  At least with the patio door (which has the red card) I can see when the lock is open/closed and program off those types of events, have it lock when I hit goodnight, etc.  

Any ideas if I am missing something simple?

What is the firmware on the yellow card? If its low enough it might not have supported the 10 digit keypads. 

You'll also need to reset the lock to tell the card you have a 10 digit keypad now. 

Pull the battery and then hit the big button the back to drain the power.  With the yellow card in, press the large button on the back and then push the battery sled in.  Keep holding the button for a few seconds then release it.  This should factory reset the lock and the card and make sure the card knows its a 10 digit keypad. 

-Dan

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...