Jump to content
C4 Forums | Control4

foscam ip camera integration


wpervaiz

Recommended Posts

I have a bunch of foscam cameras (dont ask! :P) that need to be integrated into a system. I need them to stream to touchpanels/mobile devices as well.

My problem is that none of the axis/panasonic cameras work. The 'web image' cameras need a jpeg/mjpeg extension to work...

What I've found out about these foscams is that the page:

http://ip_addr/live.htm

gives me a page with a live stream... also, this url:

http://ip_addr/video.cgi

gives me the standalone video stream.

None of the existing drivers will accept the /video.cgi part to stream... any ideas? how do i edit these to make them work? Is there an alternate driver for generic ip cameras?

Many thanks!

Link to comment
Share on other sites


ok, for anyone who's looking for a similar solution...

i took the axis233 (ip ptz) driver from the "drivers/virtual" directory and edited it...

basically, the .jpg and .mjpeg urls inside of the 'URL' tags get replaced by something like this:

http://camera_ip/video.cgi?user=[username]&pwd=[Password]

then, just add the modified driver in composer. you don't need to enable http authentication...

I know, not the best of programming with the password being hard-coded, but hey, it works perfectly.... and i get the same functionality of axis from a sub $100 camera!

Link to comment
Share on other sites

  • 1 month later...

Hi wpervaiz,

Could please ask a huge favour? Would it be possible please to e-mail me wih a copy of your modified driver used for the Foscam IP camera? I've tried modifying the axis233 (ip ptz) driver driver with no joy and figured it would be simpler and quicker to replace the driver with your modified one. I am happy to modify it with my IP address etc.

Thanks in advance wpervaiz

Link to comment
Share on other sites

sorry for the late reply guys....

I'm attaching the file here. There are a few steps you'll need to take to make this work with your cameras:

1. Edit the .c4i file and replace all instances of [uSERNAME] and [PASSWORD] with a valid username and password from the foscam camera logins table

2. Put the file in the my documents\control4\drivers directory and launch composer

3. Go to the search tab, device type=others, manufacturer=foscam

4. Add this to your project and type in the IP address of your camera. port should be set to 80

5. since you're doing authentication inside the driver file, keep the "http authentication" checkbox unchecked.

6. NOTE: you won't be able to TEST connection. for some reason it doesn't verify connection to the camera, but the camera will work

The file attached is a half modified AXIS file. I changed only parts that I needed. Feel free to make more changes and help the community if you think you improved the driver.

Best,

Waleed

Link to comment
Share on other sites

Hi Waleed,

Thank you for providing the modified file and detailed description for the installation.

I have followed your instructions, but l am not able to see Camera icon on my iPad. To test things, l had also installed the original axis driver and was able to see the camera icon.

Any suggestions what would cause this?

Is there anyone experiencing this issue?

Thanks in advance

Link to comment
Share on other sites

  • 5 months later...

I had been struggling trying to get Waleed's driver to work also. Turns out just copying his driver to documents\control4\drivers didn't work for me. I ended up using his driver and copying and pasting the applicable parts into an existing camera driver in my C:\Program Files\Control4\Composer182\Drivers\Virtual directory, and then restarting composer, and adding the changed camera driver to the project

for the Get_Image url I used

/snapshot.cgi?user=XXXXXXX&pwd=XXXXXXX&resolution=8

and for the Get_MPEG url i used

/video.cgi?user=XXXXXXX&pwd=XXXXXXX&resolution=8

The resolution of 8 is based on the Foscam CGI manual. It doesn't use 640x480 and 320x240 in the URL to call the resolution like the panasonic and Axis cameras do, it instead uses 8, and 32 to call the resolution. This means that i haven't been able to get control4 to switch resolutions on its own. I've only been able to set a specific resolution in the driver itself.

You can also change the Pan Tilt URL's as Waleed indicated in his previous post. Although i was successful without adding my username and password and instead only used "/decoder_control.cgi?command=4" for PAN_LEFT example

Here is the Foscam CGI manual http://www.computersolutions.cn/blog/wp-content/uploads/2010/04/IP-Camera-CGI-%E5%BA%94%E7%94%A8%E6%8C%87%E5%8D%97-1.11.pdf

Link to comment
Share on other sites

I had been struggling trying to get Waleed's driver to work also. Turns out just copying his driver to documents\control4\drivers didn't work for me. I ended up using his driver and copying and pasting the applicable parts into an existing camera driver in my C:\Program Files\Control4\Composer182\Drivers\Virtual directory, and then restarting composer, and adding the changed camera driver to the project

for the Get_Image url I used

/snapshot.cgi?user=XXXXXXX&pwd=XXXXXXX&resolution=8

and for the Get_MPEG url i used

/video.cgi?user=XXXXXXX&pwd=XXXXXXX&resolution=8

The resolution of 8 is based on the Foscam CGI manual. It doesn't use 640x480 and 320x240 in the URL to call the resolution like the panasonic and Axis cameras do, it instead uses 8, and 32 to call the resolution. This means that i haven't been able to get control4 to switch resolutions on its own. I've only been able to set a specific resolution in the driver itself.

You can also change the Pan Tilt URL's as Waleed indicated in his previous post. Although i was successful without adding my username and password and instead only used "/decoder_control.cgi?command=4" for PAN_LEFT example

Here is the Foscam CGI manual http://www.computersolutions.cn/blog/wp-content/uploads/2010/04/IP-Camera-CGI-%E5%BA%94%E7%94%A8%E6%8C%87%E5%8D%97-1.11.pdf

Thanks jbing1982!! I've been away for a while, but I'll see if i can help anyone who can't get this solved using jbing1982's method above. I havent personally tested it on the iPads, so I'm not sure how that would work.... just the OSD and iPhone for me right now.

Link to comment
Share on other sites

jbing1982:

What driver did you edit? I tried the 207W because these are fixed cams and nothing shows up in Flash or legacy Web Navigator. Are you using the "[" delimiter with the username/password? I feel like I'm 18 again with all this stuff. I haven't been stumped like this in years. Any chance you could attach your edited driver?

Link to comment
Share on other sites

For no particular reason i used the "camera_ip_http_panasonic_KX-HCM110A.c4i" driver in the Virtual directory. As you can see i only changed what i needed to so that i worked with the Foscam camera, i left the name and everything else the same.

Link to comment
Share on other sites

  • 5 months later...

Is there a way to get the 'Focus Near' to be theUP function and the 'Focus Auto' to be the DOWN function?

I see the 'Zoom in' is left, 'Zoom out' is right and 'Focus Far' is stop. Again, spectacular effort!

Link to comment
Share on other sites

  • 1 month later...

I am looking for a little insight. I have tried both of these drivers and have been unable to get them to work. In both cases the driver loads and I can configure but the camera never can be displayed on the on screen Nav or iPad. It adds the camera but an image is never displayed. Any help would be appreciated.

Mark

Link to comment
Share on other sites

  • 1 month later...

hey guys - newbie here. I am trying to reach my Foscam FI8918W camera (while addressable), the camera fails to Test a valid connection. Any tips and/or hints? much appreciated. thank you :-)

PS: i did attempt to choose the default panasonic_KX-HCM110A as well as the modified driver provided by jbing1982 but neither have panned out so far :-(

ankur

Link to comment
Share on other sites

When you say you tried the panasonic, did you modify the driver by putting in your login information and correct resolution? I recently purchased one of these cameras, just to try out, and was able to get it integrated with Control4 (limited integration) by modifying the driver like jbing describes. I have not really tested the pan/tilt functionality yet, but I have gotten the picture to pull up on navigator, etc.

Link to comment
Share on other sites

yep - i did: updated username, password and resolution - both as a URL as well as param. status is Device Addressed, upon selecting test though - it attempts and then reverts to "Retrying..." is there a way to find out what the error message is? can't reach host, creds, syntax, etc.?

as always, appreciate any tips and hints.

ankur

Link to comment
Share on other sites

  • 3 months later...

I am trying to add presets to the driver, but I can't seem to pass the right value.

<command>

<name>PRESET</name>

<URL>/decoder_control.cgi?command=[Preset]&user=[uSERNAME]&pwd=[PASSWORD]</URL>

<params>

<param>

<name>Preset</name>

<values>

<value>31</value> (go to preset 1)

<value>33</value> (go to preset 2)

<value>35</value> (go to preset 3)

<value>37</value> (go to preset 4)

</values>

</param>

</params>

</command>

However, when you click on Preset 1 in the GUI, it always sends the value "1". It appears there is no way to map the value of "Preset 1" in the gui?

Axis & Panasonic presets look like this:

<name>Preset</name>

<values>

<value>1</value> (go to preset 1)

<value>2</value> (go to preset 2)

<value>3</value> (go to preset 3)

<value>4</value> (go to preset 4)

</values>

Anyone look into this?

Link to comment
Share on other sites

Unfortunately, most of the params sections in the IP Camera driver are a figment of someone's imagination.

They don't do what you'd think they should.

They always send 1, 2, 3, 4, etc. You could certainly change the URL you send, and put a '3' in front of it, so you could get 31, 32, 33, 34, etc., but you can't arbitrarily send a 31, 33, 35, etc...

Sorry.

RyanE

Link to comment
Share on other sites

  • 3 weeks later...

I need help completing the PTZ for this driver ......

Foscam ip driver .... the pan and tilt doesn't stop . If I press the left, right, up or down button, the camera turn but doesn't stop !!! On the touchscreen, iphone or ipad, I'm not able to just touch the screen to make the camera turn..... I have to use the Zoom in Zoom out

HELP HELP HELP !!!!!!!!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...