Jump to content
C4 Forums | Control4

HE2.2.0 crashes on startup?


Recommended Posts

I just updated HE from 2.1.1 to 2.2.0. After I installed it, it fired up and found the Director. When I tried to connect to the Director, the software gave a "Fatal Error" with the following info. I have unstalled and reinstalled it--no luck. Has anyone seen the error ... got ideas on what to do? (HE2.1.1 still works.) Thanks.

Exception: System.ArgumentNullException

Message: Value cannot be null.

Parameter name: buffer

Source: mscorlib

at System.Security.Cryptography.HashAlgorithm.ComputeHash(Byte[] buffer)

at Control4.Client.Controller.PerformChallengeResponse()

at Control4.Client.C4System.ConnectToController(String ipAddress, String filename, String systemPassword)

at Control4.Client.C4System.ConnectToController(String ipAddress, Int32 port, String filename, Boolean useSsl, String systemPassword)

at Control4.Designer.DesignerForm.ConnectToController(String uuid, String ipAddress, Int32 port, String filename, String username, String password, Boolean useSsl)

at Control4.Designer.DesignerForm.ConnectToController(String uuid, String ipAddress, String username, String password)

at Control4.Designer.DesignerForm.ConnectToLocalController()

at Control4.Designer.DesignerForm.ShowStartup()

at Control4.Designer.DesignerForm.ShowStartupOnFirstRun()

at System.Windows.Forms.Control.InvokeMarshaledCallbackDo(ThreadMethodEntry tme)

at System.Windows.Forms.Control.InvokeMarshaledCallbackHelper(Object obj)

at System.Threading.ExecutionContext.runTryCode(Object userData)

at System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode code, CleanupCode backoutCode, Object userData)

at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state)

at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)

at System.Windows.Forms.Control.InvokeMarshaledCallback(ThreadMethodEntry tme)

at System.Windows.Forms.Control.InvokeMarshaledCallbacks()

Link to comment
Share on other sites

  • 2 weeks later...

I've run into this before. Can't remember the exact fix, but basically there is a corrupt XML file in your 2.2 install directory.

If you open the xml files and find one that has no data in it, that is the one causing the issue. Thus the "null" error.

Might be a simple as copying that same xml file from your 2.1 folder to 2.2 or restore it from backup.

For whatever reason, reinstalling does not copy a new version of the xml files. And if it sees the xml file there, it won't recreate it.

It is really sloppy programing, since it's basically a static xml file and needs to be there to run and contain info. No real error handling = sloppy coding.

Link to comment
Share on other sites

Thanks. I'll look into it and let you know what I find.

Ok, here's an update. I had my rep upgrade me to Director 2.2. Then I ran Composer 2.2, which I had previously installed; it worked! Thanks to all.

PS. I still have an issue with a lost icon for the application. I have uninstalled/reinstalled Composer 2.2. I even ran a utility I got off the web that should fix the problem. It did for the large icon but not the task bar. I think this is a Windows 7 problem.

PSS. If anyone from Control 4 is listening, why not check for Director 2.2 when installing Composer 2.2; if it's not there give a message and stop???

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.