Jump to content
C4 Forums | Control4

Question about Version Incompatibility


BrettB0727

Recommended Posts

I read so much on here from everybody about how all your versions of everything should match up, or stuff probably won't work. But then I got to thinking, is this really a huge problem?

I mean at the very least I would hope that the software is backwards compatible(though I have definitely been learning on here that practicality is not always the Control4 way). I would think that the latest would be able to handle everything before it.

Do dealers really have about a dozen or more copies of Composer Pro installed?!?!?!? that way they can handle any customer's system. Or do dealers just use one copy(the latest)?

(I do however complete understand 1.7.4 might not be able to handle a 2.0.6 controller as it might not understand some of the newer features)

Thanks in advanced for answering my newbie question! :D

- Brett

Link to comment
Share on other sites


I have every major version of Composer Pro installed on my PC. You can usually use the latest major Composer release on any version in the same major release train. For example 2.0.6 can be used for any 2.0 version.

This is not only true for Composer but also for firmware version on hardware. For example if you were running 2.0.6 firmware on a dimmer and purchased an older dimmer on say 1.7 the firmware would no match. The 1.7 firmware will need to be upgraded.

Link to comment
Share on other sites

I have every major version of Composer Pro installed on my PC. You can usually use the latest major Composer release on any version in the same major release train. For example 2.0.6 can be used for any 2.0 version.

This is not only true for Composer but also for firmware version on hardware. For example if you were running 2.0.6 firmware on a dimmer and purchased an older dimmer on say 1.7 the firmware would no match. The 1.7 firmware will need to be upgraded.

Wow that amazes me(but less so after a lot of reading on the forum)... I guess this method fits their model, helping both Control4 and dealers charge for things like upgrade. Just looked at their website and I guess they are still a very new and small shop!

Thanks for the info, Hennie!

- Brett

Link to comment
Share on other sites

I read so much on here from everybody about how all your versions of everything should match up, or stuff probably won't work. But then I got to thinking, is this really a huge problem?

I mean at the very least I would hope that the software is backwards compatible(though I have definitely been learning on here that practicality is not always the Control4 way). I would think that the latest would be able to handle everything before it.

Do dealers really have about a dozen or more copies of Composer Pro installed?!?!?!? that way they can handle any customer's system. Or do dealers just use one copy(the latest)?

(I do however complete understand 1.7.4 might not be able to handle a 2.0.6 controller as it might not understand some of the newer features)

Thanks in advanced for answering my newbie question! :D

- Brett

I can't think of many features that have been truly *lost* since the beginning? The reason for different copies of composer is the way that drivers and different programming is structured. 1.7 has no clue about support for zigbee pro secure mesh networks and macros for example. Media management database in 2.0 is different than in 1.8 and previous. 1.3.2 has no clue about Rhapsody (introduced in 1.6). So for best results, you match the version of composer to the version of firmware your system is running. I manage systems on 1.7.4, 1.8.2, 2.0.. if it's not broke, why upgrade it? I fail to see how needing different versions of composer is a ploy to force you to upgrade?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...