Jump to content
C4 Forums | Control4

Programming trouble with alarm and sensors


Recommended Posts

I have a DSC IT-100 with several hard wire door and windows sensors that have been correctly operating and showing the open and closed status correctly for about a year. Recently I decided to do some programming where, when the security system enters an alarm state that the C4 system sends out an alert emailing me what zone (window/door) triggered the alarm state and turn the lights on in that zone as well as make an audible announcement in my bedroom.

Unfortunately my current programming seems to think all zones (door/windows) are open when the alarm goes off. Here is what my current programming looks like:

screenshot20111028at103.png

This programming executes every single line of code as if all windows/ doors are open even though only one is open. I have tested the sensors and they are correctly showing the status of the various doors/windows on the navigators.

Any suggestions?

Link to comment
Share on other sites


Sure, power-cycle your IT-100. Mine does the same thing until I do that. Culd just be me but it's easy to try.

Thanks for the suggestion. After power cycling, only one zone is stuck in the open state. Ill try another power cycle. Is this something you have to perform often? Do things seem to get out of sync on a regular basis, requiring a reboot?

Thanks

Link to comment
Share on other sites

Nope, only if you power-cycle the HC that the IT-100 is connected to. Another thing I've noticed with programming off of sensors is sometimes I need to remove the conditional then add it back in. Or, simply try executing the program while in Composer.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...