Jump to content
C4 Forums | Control4

Has anyone improved the Denon AVR-4308CI Serial Driver?


orrinc

Recommended Posts

The response from the Denon is pretty sluggish, and there are a lot of missing features. The notes suggest a lot of changes, but they appear to be referring to older versions of Composer.

Has anyone got a better driver than the one included with Compser that they would care to post and share?

Thanks!

Orrin

Link to comment
Share on other sites


I'm not surprised b/c I'm using a denob 3808ci and my dealer opted to control it via ir. Even with the ir, it would appear that the select button used in the denon gui does not work for the c4 select button. I'm guessing that we'll get better serial control once the new software is released.

tum

Link to comment
Share on other sites

  • 4 months later...

I want to resurrect this thread and ask a further question. It seems like the Denon 4308 takes several seconds to re-sync after switching inputs. The normal behavior of a control4 "connection" creation is to turn on the devices and then set their inputs as appropriate. Whatever signal is getting sent to the Denon forces a re-sync even though the input was likely already set.

Is there any improvement in the driver possible?

If not, can we add a state variable that remembers what the input is currently set to and only changes the input if different than current setting?

Link to comment
Share on other sites

I want to resurrect this thread and ask a further question. It seems like the Denon 4308 takes several seconds to re-sync after switching inputs. The normal behavior of a control4 "connection" creation is to turn on the devices and then set their inputs as appropriate. Whatever signal is getting sent to the Denon forces a re-sync even though the input was likely already set.

Is there any improvement in the driver possible?

If not, can we add a state variable that remembers what the input is currently set to and only changes the input if different than current setting?

I have all inputs connected to AV Matrix switch and only one set of connections to the Denon Receiver on TV input. The Denon re-sync drove me crazy. I got around this by giving the C4 Denon Driver a fake command for Denon TV Input and the correct Denon TV input on a new command called Denon Room. Now C4 automatic command to change the Denon Receiver to TV input does nothing. So in Programming, I enterred command When Room is Turned On send command Denon Room. Now when the Room is first turned on the Denon Receiver is set to the correct input once. The AV Matrix Switch changes all inputs and the Denon quickly syncs to the inputs. Re-sync issue was solved.

You could do similar programming with a fake command on the original inputs driver and use variables for the correct input.

How is your equipment connected to the Denon Receiver?

Link to comment
Share on other sites

id love to see an IP driver.. with driverworks it would be possible. you can do everything via web page control on the 4308 already. i have a 4306 and would love an ip based driver. Discrete volume would be amazing. The serial drivers for denon are definatly not right. The power comands are all messed up with the 2 way serial drivers right now. It would take time, but every serial command is available from denon.

Link to comment
Share on other sites

I want to resurrect this thread and ask a further question. It seems like the Denon 4308 takes several seconds to re-sync after switching inputs. The normal behavior of a control4 "connection" creation is to turn on the devices and then set their inputs as appropriate. Whatever signal is getting sent to the Denon forces a re-sync even though the input was likely already set.

Is there any improvement in the driver possible?

If not' date=' can we add a state variable that remembers what the input is currently set to and only changes the input if different than current setting?[/quote']

I have all inputs connected to AV Matrix switch and only one set of connections to the Denon Receiver on TV input. The Denon re-sync drove me crazy. I got around this by giving the C4 Denon Driver a fake command for Denon TV Input and the correct Denon TV input on a new command called Denon Room. Now C4 automatic command to change the Denon Receiver to TV input does nothing. So in Programming, I enterred command When Room is Turned On send command Denon Room. Now when the Room is first turned on the Denon Receiver is set to the correct input once. The AV Matrix Switch changes all inputs and the Denon quickly syncs to the inputs. Re-sync issue was solved.

You could do similar programming with a fake command on the original inputs driver and use variables for the correct input.

How is your equipment connected to the Denon Receiver?

I think I understand your solution and see how it works for you, but I'm using multiple inputs on my Denon, so I can't disable the actual code for the (Tivo) input because when I switch to some other input (ps3, appletv) I'll need the C4 system to send the right signal to change it back to Tivo.

There are state variables available for "when input changes" but nothing to query what the input is set to. In addition, I don't see how to change the driver to execute a C4 script for the change-input command to actually check a state variable.

Link to comment
Share on other sites

I think I understand your solution and see how it works for you, but I'm using multiple inputs on my Denon, so I can't disable the actual code for the (Tivo) input because when I switch to some other input (ps3, appletv) I'll need the C4 system to send the right signal to change it back to Tivo.

There are state variables available for "when input changes" but nothing to query what the input is set to. In addition, I don't see how to change the driver to execute a C4 script for the change-input command to actually check a state variable.

When do you have the re-sync issues? Changing from Tivo to PS3 or AppleTV? I think this is normal behavior for Denon when switching inputs.

I would use the C4 state variable found in programming for the room. My room name is Den and looks like the following.

"When the variable Den-Current_Selected_Device changes". See this post for an example I use to change aspect ratio. http://www.mdaoe.com/smf/index.php?topic=798.0

Create a variable for each device. Under "When the variable Den-Current_Selected_Device changes" add "If Video Device is Tivo", then "Set Varibale Tivo to True".

Link to comment
Share on other sites

it used to be worse whenever we had everything at native resolution, having the denon switch between 720p and 1080i/p and the tv would go nuts waiting for a signal. Since changing everything to 720p only in the project I'm talking about, it hasnt been as bad - but the delay in detecting and displaying resolutions was killer, esp when going from say 1080i satellite to the c4 menu and back.

Link to comment
Share on other sites

what IS the issue?

I'm watching tivioHD (at 1080p). I turn the system off.

I hit WatchTV (on the new RC250 :-) and it turns the system on, showing TivoHD as the selected input. The Denon and TV are powered on, I pretty quickly see the Tivo output on the TV, then... something happens and the sync is lost for 2-3 seconds and it comes back. Simply power-cycling the denon does _not_ cause the same behaviour, so I think it is the explicit set-input-to-Tivo command being sent to the Denon and the Denon is being stupid about not noticing that oldinput==newinput.

Theoretically the HC500 video never gets enabled in this sequence (and I don't see it).

Since this is the 90% use case of my AV system, it's unfortunate.

(TV is Sharp 65" 94SE... see my other question about power-on macro (off+toggle??))

Link to comment
Share on other sites

  • 2 months later...

HELP

I just got a Denon 4308CI and have been trying to get it to work with my system. IR sensor is on the left side, and flashes with the commands that are on the Denon 4308ci driver thru Composer 1.6 i.e. on, off, DVD and nothing happens with the Amp, are the drivers ok? I went to edit driver, and tried to input the IR signals, and my Media controller will not recognize them. Please help.......

Thanks.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...