patdaman45

Registraion Error - 403

33 posts in this topic

Hi, I'm a network guy trying to register a control4 system to a new client.  It was previously registered to the old homeowners account and when trying to register it to the clients newly created account they receive a "403 unauthorized" error.  Even when trying to re-register to the old account it fails with the same error.  I'd be happy to pay someone to help me figure this out as they cannot use their Rhapsody service because of it.

Thanks!

Share this post


Link to post
Share on other sites

Do you have proper credentials to register the controller to the new dealer of record?

Share this post


Link to post
Share on other sites
3 hours ago, patdaman45 said:

as they cannot use their Rhapsody service because of it.

Beware - merely registering may not fix that - if the system is not at east a 2.8.2 already, it will need to be updated, and if it's pre 2.6 now, that MAY be a BIG undertaking.

Share this post


Link to post
Share on other sites
2 minutes ago, funnyfarm299 said:

Important question here is what system software version they're on. That will answer a lot.

Good point - I'm going to guess pre 2.2.2, which means the system has to be updated (and on-site) to even begin to connect in the first place.

Share this post


Link to post
Share on other sites

Its running 2.5.3.  After doing some research it seems like 2.8.2 is the cut off for Rhapsody but registration should still work.

Share this post


Link to post
Share on other sites
7 minutes ago, patdaman45 said:

Its running 2.5.3.  After doing some research it seems like 2.8.2 is the cut off for Rhapsody but registration should still work.

Yes, assuming a variety of things are set up / configured correctly. When you unregistered it from the old account, how did you do it?

Share this post


Link to post
Share on other sites
18 minutes ago, funnyfarm299 said:

Yes, assuming a variety of things are set up / configured correctly. When you unregistered it from the old account, how did you do it?

We unregistered the controller in Composer and then made sure that the client removed it from their customer.control4 login.

Appreciate the help!

Share this post


Link to post
Share on other sites

Tools -> System Manager -> Controller Networking -> Test Internet Connection. Post results.

Also post the full text from composer when trying to register.

Share this post


Link to post
Share on other sites

i know there have been some registration error with a few of our controllers. we have been having to change the network to dns 8.8.8.8 and 8.8.4.4

Share this post


Link to post
Share on other sites

I have an old H200. I tried to scan for new media, and my system told me that I needed to reregister my controller. I did that, but when trying to re-register the controller I get an ssl error. Based on the comment above from Matt, do I need to change my DNS in the controller to fix this issue? 

Appreciate any help!

Share this post


Link to post
Share on other sites

Based on the above posts, I'd start by checking and stating what version your system is on, as it's more likely that it's....and ssl error due to licensing expiring, requiring upgrades and/or patches.

Share this post


Link to post
Share on other sites

I am on version 1.8.2. That was the newest I thought the HC200 could support. The system has worked flawlessly for the past 7 years. What licenses would expire that I can check? Are there any new patches for my version that would be required? I verified that it has the old THWARTY patch that caused this issue years ago.  

I have the myHome Site license, but it never expires. But since the error, my ipads are no longer able to access my system.

I have attached a copy of the error.

Many thanks!

Screenshot 2017-01-06 15.37.33.png

Share this post


Link to post
Share on other sites

Is there a new one? I verified that it has the Thawte-Ssl-Update already. What can I tell my dealer to look for? Any info would cut down on my cost for him to troubleshoot! 

Thanks Guys!

PS my dealer can't help until next week. Is there anyone here that can do this remotely for me today?

 

Share this post


Link to post
Share on other sites

As stated earlier in the thread by me, NO systems pre 2.2.x can contact the servers anymore, you'll have to get your system updated first. And a 200 can run up to 2.5.3.

Share this post


Link to post
Share on other sites

Awesome! I didn't know that. How do I get it updated? can it be done remote, or can I expect to need a house visit? The update manager says I am on the current version and no update is available. Will all my older hardware and remotes work on the newer version? I thought there was issues with that.

Share this post


Link to post
Share on other sites
3 minutes ago, mstorrs said:

Awesome! I didn't know that. How do I get it updated? can it be done remote, or can I expect to need a house visit? The update manager says I am on the current version and no update is available. Will all my older hardware and remotes work on the newer version? I thought there was issues with that.

That's the thing with it not able to connect to online services, updating will have to be done locally using a usb update stick. As far as hardware limitations, if you are on 1.8.2 now, there are non as the remotes that stopped working wouldn't work on 1.8.x and up.

Share this post


Link to post
Share on other sites
3 hours ago, Cyknight said:

That's the thing with it not able to connect to online services, updating will have to be done locally using a usb update stick. As far as hardware limitations, if you are on 1.8.2 now, there are non as the remotes that stopped working wouldn't work on 1.8.x and up.

Has to be done locally, but the device image updater is an option too.

Share this post


Link to post
Share on other sites
2 hours ago, funnyfarm299 said:

Has to be done locally, but the device image updater is an option too.

Not on a 200 running 182, it'll be the original series so no factory restore.

Share this post


Link to post
Share on other sites
40 minutes ago, Cyknight said:

Not on a 200 running 182, it'll be the original series so no factory restore.

I'm still so freaking confused on this one. I've also had difficulty running this on these older controllers, but per KB comments and discussions with others, this SHOULD work. I'll ask more info on Monday.

Share this post


Link to post
Share on other sites

Thank you all for your help!

For final confirmation, The HC 200 can be upgraded from 1.8.2 directly to 2.5.3 using the USB stick? No need to have any other controllers like a HC 300 in the system to do the upgrade ? And, no way that it can be force updated remotely, right?

 

Share this post


Link to post
Share on other sites

Issue Update - Any Advice? - Worked with my deal for a few hours at my house yesterday, and could not get the HC 200 to update. Nest step is to put it into another project that is already updated, to try to bring it up to 2.5.3. Can anyone tell me what my dealer couldn't figure out. Here were the steps;

1) He downloaded and then logged in locally with Composer Pro 2.5.3. Went to update manager, but it said it could not update the controller because it was not registered on the my control4 site (I was asked by my system to unregister and re-register it last week, and that is what got me in this mess. The HC 200 could not be re-registered as stated above by Cyknight). So, it was not passible to do a simple update. 

2) He created a install USB stick, put in my MAC address etc, and it selected 2.5.3 as the version to install. We put that in the controller, pulled pawer and rebooted. The system loaded just fine, but the composer both versions 1.8.2 and 2.5.3 could not see the USB stick. So, no way to update from the stick.

3) Made a new stick again and tried again, rebooted, loaded, and we got the same result.

4) made a restore disk back to 1.8.2, rebooted and it saw that just fine and restored it to 1.8.2. 

5) then tried the install 2.5.3 stick again and it still did not see the usb stick in the update manager.

6) Next step, unless you guys have something else we can try, is to restore it and put it into another system and try updating it that way. Anyone know for sure if that will work?

Seems like we are stuck in a loop where we cant register because we are not updated, but cant update because we are not registered.

Any advice/direction would be greatly appreciated.

Thanks!

Share this post


Link to post
Share on other sites

Do you know what version of HC200 you have? You may well have a HC200B (v2) which doesn't use USB update, but factory restore. In THAT scenario there's a program (network image updater) that allowsthe factory restore function to be updated to 2.5.3 (and then performs the restore right away as well).

Share this post


Link to post
Share on other sites

Here is a pic of the MAC and Model Number. Can you confirm it is a B?

IMG_5591.JPG

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
    • 7 Posts
    • 33 Views
    • 3 Posts
    • 499 Views
    • 11 Posts
    • 124 Views
    • 10 Posts
    • 86 Views
    • 1 Posts
    • 72 Views
    • 15 Posts
    • 277 Views