Jump to content
C4 Forums | Control4

Composer HE version

Recommended Posts

Quick noob question ... dealer told me to download Composer HE 2.1.1 but looking at my director itis running - Am I correct in thinking I really should be using Composer HE 2.2.1 ?

I am experiencing the "project locked" problem mentioned in another thread and thinking upgrading to 2.21 might solve the problem. Are there any gotcha's when upgrading HE?

Link to comment
Share on other sites

2.1 on a 2.2 project shouldn't be a problem but I agree, 2.2 is readily avail. so use it. Doubt it will help that project locked but maybe someone has first-hand experience.

Link to comment
Share on other sites

  • 1 month later...


My dealer updates me to 2.2 a couple of days ago. In my control4 I can only find Composer HE 2.2.1 - which pops up a message that it is not compatible wit pre 2.2.1 versions!?

Can anyone tell me where I can find Composer HE 2.2 for download or should I just keep using Composer 2.1?


Link to comment
Share on other sites


Composer HE Version 2.2.1 does not work with System OS 2.2.0, when connecting you get the following message (picture attached).

I don't know why he did not upgrade me to 2.2.1, maybe a mistake. Though for the next couple of days he is not reachable :-(.

However I can connect using Comp. HE 2.1.1.

At the moment I do have a weired light switch problem, some lights are switching themselfes off after a couple of seconds - very weired and annoying.

To troubleshoot I would like to rule out everything on my end, and that includes a matching version of Composer HE and system OS.

Version 2.2.0 does not show up in my downloads under mycontrol4 - maybe he updated me to some beta/rc version by accident?



Link to comment
Share on other sites

Your dealer will need to update you to 2.2.1 to get the message to go away.

You should be able to ignore the message in the meantime.

Yep, just ignore it.

That comes up ANY TIME there is a version mismatch. It will still work, as long as you're not trying to use it across too major of a version difference.

General rule of thumb

Use 1.7.4 for anything 1.7.x

Use 1.8.2 for anything 1.8.x

Use 2.0.6 for anything 2.0.x

Use 2.1.1 for anything 2.1.x

Use 2.2.1 (2.2.2 soon) for anything 2.2.x

For every major build, like 2.2 or 2.1, using the latest available Composer version is a good idea.

It will give you that message, ignore it and move on. If you are too far off on Composer version, you'll get other error messages, like project locked or issues with drivers.

Link to comment
Share on other sites

Since ComposerPro only talks to Director through a fairly well-defined API boundary, this is usually pretty safe.

It's always best to use the same version (thus the warning), but the major version is the minimum requirement, as stated above.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.