Jump to content
C4 Forums | Control4

ios App (latest 322.29.0) throwing lots of Migration required errors and can't connect to 4sight - ideas what needs "migrated"?


Recommended Posts

Hi all

Troubleshooting our 4sight subscription that has never worked at our location. (Even replaced the router and switches to no avail.) While looking at the ios app logs, I am seeing tons of these migration required errors. Note the system is on 3.3.0 so believe latest of everything including drivers all updated.

Ideas what driver or item needs migrated?

2022-08-22 08:58:47.092-0400 [Warning] [main] [RealmRepository.swift:42] > [C4DataKit.RealmRepository] : DEFAULT REALM CONSTRUCTED
2022-08-22 08:58:53.582-0400 [Error] [main] [RealmRepository.swift:40] > [C4DataKit.RealmRepository] : Error: Migration is required due to the following errors:
- Property 'Camera.hasExtras' has been added.
- Property 'Camera.snapshotQueryString' has been added.
- Property 'Camera.requiresDynamicStreamUrls' has been added.
- Property 'Camera.requiresDynamicSnapshotUrls' has been added.
- Property 'Camera.hasDynamicPresets' has been added.
- Property 'Intercom.protocolFilename' has been added.
- Property 'LightDevice.daylightActive' has been added.

Link to comment
Share on other sites


  • 4 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...