Jump to content
macmann

Anyone integrate Ubiquiti cameras with c4 successfully?

Recommended Posts

I have a UniFi security camera system. I like their app, time lapse features and ability to search video quickly.  Anyone successful integrate them with c4?

Share this post


Link to post
Share on other sites

On 12/31/2019 at 7:16 PM, macmann said:

I have a UniFi security camera system. I like their app, time lapse features and ability to search video quickly.  Anyone successful integrate them with c4?

Yes, just don't get the snap shot if I remember correctly. 

Honestly you are better off just using the Unifi app unless you have a real need/use for it in C4. 

Share this post


Link to post
Share on other sites

I have multiple Unifi cameras integrated with C4. If you enable anonymous snapshots in the Unifi camera config, everything works great. I can see all of my Unifi cameras in the Navigator, T3 touchscreens and the C4 app on IOS devices. This works in both Unifi independent mode and centrally managing cameras with Unifi Protect.

Share this post


Link to post
Share on other sites

@Riverguy  Are you able to get both snapshots AND the live video on the Navigators / T3s?  From my understanding I thought C4 couldn't deal with 1 IP for the video stream and a different IP for the snapshot?  Which driver are you using?

Share this post


Link to post
Share on other sites
[mention=143181]Riverguy[/mention]  Are you able to get both snapshots AND the live video on the Navigators / T3s?  From my understanding I thought C4 couldn't deal with 1 IP for the video stream and a different IP for the snapshot?  Which driver are you using?
You are correct. It can't. Only 1 IP

Share this post


Link to post
Share on other sites

I am using the individual IP of each camera in the driver (only 1 IP).  Generic driver v1.02

I was not able to get an authenticated snapshot and had to enable anonymous snapshots (directly in the individual camera web ui). This obviously requires compensating controls to secure the camera if you are concerned about unauthorized access to the camera snapshots. The live view I get appears to be a snapshot refreshed every x seconds and works in the C4 IOS app, but not the TS or Navigator. The Navigator and TS just show a snapshot that refreshes every 10 seconds.

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...