Jump to content
C4 Forums | Control4

Cannot connect with 4Sight


Recommended Posts

I renewed my 4Sight subscription after letting it lapse for a few years.  There has been a controller change since the last time I had a subscription.  When trying to connect with my iPhone, iPad etc. I get a Unable to Connect message > Your system is not reachable at this time/  Please try again later or contact your dealer for assistance . (403.22)  I have tried several time on different days; same error.  on the Customer Portal it shows the license is active.  Any help is appreciated.

 

4SIGHT

Get the most out of your smart home with voice control, Apple Watch support, automation personalization, alerts and notifications, and remote access while you’re away to ensure that you are connected at all times. Learn more.

Enabled — Your current subscription expires on December 13, 2023.

MY CONTROLLER

control4_hc250_000FFF1C0xxx

  • Activated on 9/1/2022 4:25:22 PM
  • Checked-in on 12/20/2022 3:14:48 PM
  • Smart Home OS 2.10.6

 

Link to comment
Share on other sites


On 12/20/2022 at 6:09 PM, chopedogg88 said:

and you're sure that the new controller is the one that is registered/checking-in, not the old one, right?

Hi Ari,  this is the HC250 we setup in Sept to replace my old HC250 that failed.  Attached is a screen shot from the iphone app showing the controller it is trying to connect to.  Also attached is a screen shot of my customer.control4.com MyAccount and MySystem screens.  It all looks like it matches to me ...  I can connect with the iphone app locally as well as with Composer 

IMG_31416383C28C-1.jpeg

Screen Shot 2022-12-22 at 4.46.50 PM.png

Screen Shot 2022-12-22 at 4.52.54 PM.png

Link to comment
Share on other sites

On 12/22/2022 at 5:04 PM, bill said:

Hi Ari,  this is the HC250 we setup in Sept to replace my old HC250 that failed.  Attached is a screen shot from the iphone app showing the controller it is trying to connect to.  Also attached is a screen shot of my customer.control4.com MyAccount and MySystem screens.  It all looks like it matches to me ...  I can connect with the iphone app locally as well as with Composer 

IMG_31416383C28C-1.jpeg

Screen Shot 2022-12-22 at 4.46.50 PM.png

Screen Shot 2022-12-22 at 4.52.54 PM.png

Any ideas on this?

Link to comment
Share on other sites

  • 4 weeks later...
4 hours ago, cjh said:

@bill Did you get this sorted? I have a similar issue (much later controller and OS3) - everything works but 4Sight. Never has worked. Wondering if / how you got this sorted?

I got this from Control4 Customer Advocacy "At this point, I am seeing that Access Anywhere is not working correctly. The dealer would need to contact our technical support for further assistance in resolving the issue. "

 

I did not try yet as my dealer is suggesting that I upgrade to a newer controller and OS3 to eliminate the problem.  Maybe this can help you.

Link to comment
Share on other sites

One general thing with 4Sight is your DNS servers. Sometimes ISP DNS just doesn't pass through well - make sure at least the controller is set to use google or cloudflare 8.8.8.8 and 8.8.4.4 or 1.1.1.1 and 1.0.0.1 or a combination of those

Link to comment
Share on other sites

Yeah I've been helping Bill remotely, can't seem to figure this one out.  Tried changing the DNS settings, no help.  I'm able to remote into the system with Composer without issue.  Only other thing I can think of is some firewall setting blocking traffic?

Link to comment
Share on other sites

Thx @bill  

I’ve struggled with this for a year and given up. On an ea5…os3 (latest release up to one week ago). Latest apps on iphone 14’s - no love with 4sight. Tries to connect and then times out. 
 

Granted, we run pfsense for all network routing and adguard home for dns. No vlans for any of the c4 equipment. Even changed ISPs (cable to fiber).  Prior we had a cisco router and used cloudflare dns servers. I’ve even created a new c4 customer account and had the controller registered to that new account.  The controller is checking in fine w c4 and backups/uploads a copy of the project weekly to c4. That all is fine. Just 4sight doesn’t work. And yes, valid 4sight on the new customer account.  
 

I looked into the c4 app logs some time ago and couldn’t find anything obviously wrong. My understanding is that the network topology is essentially iphone c4 app —> c4—>vpn tunnel->controller. Right? (Would love somebody to confirm this) If so - and given the controller is checking in correctly to c4–I struggle to see how network nat or dns would play here as culprits???

Welcome more insight from anybody who has had this problem and figured it out ;)

Link to comment
Share on other sites

app contacts c4 server, c4 server contacts system, system and app connect over vpn. That's not QUITE the same.

Best guess (and a guess it is) is that the c4 server is being blocked from contacting the system. Double NAT COULD do that. Poor DNS can cause issues in the last step, but not likely the issue in your scenario.

pfsense is out of the box really clamped down though. It would be the first thing I'd look at for blocking remote access. I don't know it well enough though to give any direct advise on what to look for in it's settings.

Link to comment
Share on other sites

9 minutes ago, chopedogg88 said:

I've noticed over the years that just about every client I have who is a "network guy" and maintains their own firewall and network has all sorts of network-related issues :)

+1 - DNS filtering, and firewalling are great BUT you have to spend a lot of time tuning.

Link to comment
Share on other sites

Fair points. That said, the same issue was happening on a off the shelf cisco RV router and no adguard home using cloudflare dns … 

Would somebody be so kind to send me/attach here their sanitized iOS c4 app logs for a successful remote/4sight connection? Settings…preferences…email logs … would love to compare what  working logs look like compared to my not working connection. TIA

Link to comment
Share on other sites

4 hours ago, msgreenf said:

I don't think it's a problem with the app. I think it's a problem with your network blocking control. 4. Communication back from the system to the cloud

I’m with you on that. My problem is (has been) diagnosing where that block is originating. My thought is that if I compare a working session log to a non working it would inform what might be blocking. Make sense? I’m open to other ideas. I’m also open to (once again) resigning to let this just not work. 

Link to comment
Share on other sites

So what about At this point, I am seeing that Access Anywhere is not working correctly. The dealer would need to contact our technical support for further assistance in resolving the issue. "  

 

What and where is Access Anywhere?

Link to comment
Share on other sites

51 minutes ago, bill said:

So what about At this point, I am seeing that Access Anywhere is not working correctly. The dealer would need to contact our technical support for further assistance in resolving the issue. "  

 

What and where is Access Anywhere?

Access anywhere is the remote access part of 4sight. 4sight is a collection of services. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...